Autore Topic: file forum risultano versione 2.0.6 il database corrisponde alla versione 2.0.5  (Letto 1111 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline BELFA

  • Sr. Member
  • ****
  • Post: 312
    • Mostra profilo
    • Download Destination
  • Versione SMF: 2.0.x
Buongiorno a tutti.
come da oggetto allego screen dell errore che si presenta in fase di attivazione o negazione iscrizione utente

inoltre rimane la dicitura utente in attesa approvazione

mentre invece in base alla mia azione in gestione utenti è 0


Disinstallando la mod  drafts2.0.1.zip http://custom.simplemachines.org/mods/index.php?mod=1264

tutto torna normale, ora non vorrei perdere questa comoda funzione, soluzione ...
ovviamente uso la versione 2.0.6 come piattaforma

Allego Subs-Members.php  grazie per l attenzione 
 

« Ultima modifica: Giovedì, 28 Novembre 2013 18:58 da BELFA »

Offline emanuele

  • Amministratore
  • *****
  • Post: 4533
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:file forum risultano versione 2.0.6 il database corrisponde alla versione 2.0.5
« Risposta #1 il: Giovedì, 28 Novembre 2013 11:10 »
Il mod l'hai installato ex-novo oppure l'hai aggiornato da una versione precedente?
Vai in phpmyadmin e controlla la tabella smf_drafts ha un colonna id_member, se non ce l'ha (ma in tal caso suppongo i draft non potrebbero funzionare...), aggiungila, tipo di dati int.

Offline BELFA

  • Sr. Member
  • ****
  • Post: 312
    • Mostra profilo
    • Download Destination
  • Versione SMF: 2.0.x
Re:file forum risultano versione 2.0.6 il database corrisponde alla versione 2.0.5
« Risposta #2 il: Giovedì, 28 Novembre 2013 14:13 »
la mod installata come nuova, in myadmin ho questo



al posto di mediumint(8)   metto int(10) ?


Offline emanuele

  • Amministratore
  • *****
  • Post: 4533
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:file forum risultano versione 2.0.6 il database corrisponde alla versione 2.0.5
« Risposta #3 il: Giovedì, 28 Novembre 2013 14:19 »
No, meglio se correggi il codice:
In Subs-Members.php, trova:
Codice: [Seleziona]
WHERE id_member IN ({array_int:users})',e sostituiscilo cone:
Codice: [Seleziona]
WHERE member_id IN ({array_int:users})',

Offline BELFA

  • Sr. Member
  • ****
  • Post: 312
    • Mostra profilo
    • Download Destination
  • Versione SMF: 2.0.x
Re:file forum risultano versione 2.0.6 il database corrisponde alla versione 2.0.5
« Risposta #4 il: Giovedì, 28 Novembre 2013 14:55 »
mi da diverse righe con
Codice: [Seleziona]
WHERE id_member IN ({array_int:users})',devo sostituirle tutte ? o solo le righe 358 e 369 ?

Offline emanuele

  • Amministratore
  • *****
  • Post: 4533
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:file forum risultano versione 2.0.6 il database corrisponde alla versione 2.0.5
« Risposta #5 il: Giovedì, 28 Novembre 2013 17:28 »
Quella che da l'errore, quindi solo quella a 369.

Offline BELFA

  • Sr. Member
  • ****
  • Post: 312
    • Mostra profilo
    • Download Destination
  • Versione SMF: 2.0.x
Re:file forum risultano versione 2.0.6 il database corrisponde alla versione 2.0.5
« Risposta #6 il: Giovedì, 28 Novembre 2013 18:58 »
Risolto, grazie Emanuele  :)

 

Installare mod non aggiornate alla vostra versione SMF

Aperto da DarknicoSezione Guide - Trucchi

Risposte: 0
Visite: 1009
Ultimo post Lunedì, 25 Febbraio 2013 12:16
da Darknico
Guida all'emulazione (installare mod non aggiornati alla propria versione)

Aperto da emanueleSezione Guide - Trucchi

Risposte: 0
Visite: 4155
Ultimo post Martedì, 30 Aprile 2013 13:35
da emanuele
Aggiornamento del Simple Portal alla versione 2.3.6

Aperto da titaniumSezione Mods - Modifiche SMF

Risposte: 50
Visite: 6864
Ultimo post Venerdì, 17 Ottobre 2014 10:43
da Darknico