Italian SMF

Supporto SMF => SMF 2.0 => Topic aperto da: Lucarella - Martedì, 17 Marzo 2020 19:15

Titolo: Pagine bianche in tutto il forum
Inserito da: Lucarella - Martedì, 17 Marzo 2020 19:15
Come mi è stato fatto notare nell'altro topic, il mio forum http://emuleitalia.eu/index.php?action=forum, ai visitatori, è visibile solo la home, mentre tutte le altre sezioni danno una pagina bianca.
Finora non me ne ero mai reso conto perchè sono sempre loggato, poi grazie a Darknico ho dato uno sguardo come ospite ed ho potuto constatare il problema.
Il registro non presenta errori gravi, solo qualcuno riguardo a password non corrette da parte di alcuni utenti.
L'elenco delle mod installate è il seguente:
Citazione
1.   New Topic Button   1.0    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
2.   Regbar Warning   1.0.5    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
3.   SimplePortal   2.3.6    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
4.   Simple Youtube Video Embedder/BBC   1.1    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
5.   YandexGarland   1.2   [ Installa MOD ] [ Elenco dei file ] [ Elimina ]
6.   YouTube BBCode   2.6    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
7.   SMF 2.0.3 Update   1.0    [ Elenco dei file ] [ Elimina ]
8.   SMF 2.0.4 Update   1.0    [ Elenco dei file ] [ Elimina ]
9.   Topics list support [Taby]   1.05    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
10.   Welcome Topic Mod   2.2    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
11.   SMFPacks Shoutbox   1.0.4    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
12.   SMF 2.0.15 Update   1.0    [ Elenco dei file ] [ Elimina ]
13.   Thank-o-matic   3.0    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
14.   SimplePortal   2.3.5   [ Elenco dei file ] [ Elimina ]
15.   Topic View Log   1.2    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
16.   Alternate User Posting   1.0.1    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
17.   Custom Copyright   1.0.3    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
18.   SMF 2.0.16 Update   1.0    [ Elenco dei file ] [ Elimina ]
19.   Spoiler Tag   0.7.2a    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
20.   PM to New Members   1.2    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
21.   SMF 2.0.11 Update   1.0    [ Elenco dei file ] [ Elimina ]
22.   SMF 2.0.5 Update   1.0    [ Elenco dei file ] [ Elimina ]
23.   SMF 2.0.8 Update   1.0    [ Elenco dei file ] [ Elimina ]
24.   Group Color in Posts and Profile   1.4    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
25.   Adk bbcTorrent   1.0    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
26.   GDPR Helper   1.0.4   [ Installa MOD ] [ Elenco dei file ] [ Elimina ]
27.   Similar Topics   0.6    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
28.   ed2k links support Taby   2.8    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
29.   Glossario menu link Taby   1.0   [ Installa MOD ] [ Elenco dei file ] [ Elimina ]
30.   Integration Hooks Report   1.5.3    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
31.   Add [nobbc] button   1.1    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
32.   SMF 2.0.13 Update   1.0    [ Elenco dei file ] [ Elimina ]
33.   SMF 2.0.17 Update   1.0    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
34.   Edit BBCode Taby   1.01    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
35.   Cookies alert message   0.1.0    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
36.   Board-color-and-icons   1.1    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
37.   SMF 1.1.21 / 2.0.10 Update   1.0    [ Elenco dei file ] [ Elimina ]
38.   SMF Staff Page   1.7    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
39.   SMF 2.0.14 Update   1.0    [ Elenco dei file ] [ Elimina ]
40.   SMF 1.1.19 / 2.0.6 Update   1.0    [ Elenco dei file ] [ Elimina ]
41.   SMF 2.0.12 Update   1.0    [ Elenco dei file ] [ Elimina ]
42.   Default Avatar   2.3    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
43.   Alternate Email   1.1    [ Elenco dei file ] [ Elimina ]
44.   SMF 1.1.20 / 2.0.9 Update   1.0    [ Elenco dei file ] [ Elimina ]
45.   Hide Tag Special   3.0    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
46.   Users Online Today   2.0.3    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
47.   GDPR Helper   1.0.8   [ Installa MOD ] [ Elenco dei file ] [ Elimina ]
48.   Admin Ban Button in Post   3.1    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
49.   Adk BBC Magnet   1.0    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
50.   Tapatalk SMF 2.0 RC4/RC5/Final Plugin   3.0.1    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
51.   6 Custom buttons / tabs with Sub Menus (4)   0.5    [ Disinstalla ] [ Elenco dei file ] [ Elimina ]
52.   SMF 2.0.7 Update   1.0    [ Elenco dei file ] [ Elimina ]

Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Martedì, 17 Marzo 2020 20:14
Una pagina bianca è un errore di sintassi di php, quindi non viene registrato nel log di SMF.
Dubito che su altervista hai accesso al log degli errori del server, quindi prova a mettere queste righe in index.php:
Codice: [Seleziona]
error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);
direi all'inizio, appena dopo <?php
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Martedì, 17 Marzo 2020 21:01
Emuleitalia non è su altervista, ma su un hosting diverso, quindi ho accesso al log dal cpanel. Quello che ci ho trovato è questo:
Purtroppo il log mi fa sforare il limite di 40000 caratteri, perciò allego un file txt con gli errori presenti :P


Inoltre, ho cmq seguito il tuo suggerimento e nel registro errori non c'è nulla...

 ???
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Mercoledì, 18 Marzo 2020 18:54
Versione di php?
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Mercoledì, 18 Marzo 2020 21:21
Sul cpanel leggo 5.6.40, mentre col phpinfo leggo 5.5.38 (http://emuleitalia.eu/phpinfo.php)
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Mercoledì, 18 Marzo 2020 22:07
Prova a disabilitare simple portal... al momento non mi vengono altre idee.
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Mercoledì, 18 Marzo 2020 22:50
Fatto ma non è cambiato nulla :(

Edit
ieri sera ho aperto il forum clone che ho su altervista per i test, ho fatto qualche prova ed anche lì lo stesso problema. Adesso l'ho riaperto e sono andato a guardare il registro ed ho trovato questi errori, generati durante il mio login:

Codice: [Seleziona]
Visitatore
Tipo di errore: Indefinito
http://emuleita.altervista.org/index.php?scheduled=task;ts=1584551040
8: Use of undefined constant WIRELESS_PROTOCOL - assumed 'WIRELESS_PROTOCOL'Applica filtro: File: /membri/emuleita/Sources/Subs.php
Riga: 3263

Codice: [Seleziona]
Visitatore
Tipo di errore: Indefinito
http://emuleita.altervista.org/index.php?scheduled=task;ts=1584551040
8: Use of undefined constant WIRELESS - assumed 'WIRELESS'Applica File: /membri/emuleita/Sources/Subs.php
Riga: 3252

Codice: [Seleziona]
Visitatore
Tipo di errore: Indefinito
http://emuleita.altervista.org/index.php?scheduled=task;ts=1584551040
8: Undefined index: language
File: /membri/emuleita/Sources/Load.php
Riga: 1569

Codice: [Seleziona]
Visitatore
Tipo di errore: Indefinito
http://emuleita.altervista.org/index.php?scheduled=task;ts=1584551040
8: Undefined index: language
File: /membri/emuleita/Sources/Load.php
Riga: 1568

Codice: [Seleziona]
Visitatore
Tipo di errore: Indefinito
http://emuleita.altervista.org/index.php?scheduled=task;ts=1584551040
8: Undefined index: is_admin
File: /membri/emuleita/Sources/Load.php
Riga: 1566

Codice: [Seleziona]
Visitatore
Tipo di errore: Indefinito
http://emuleita.altervista.org/index.php?scheduled=task;ts=1584551040
8: Undefined index: is_guest
File: /membri/emuleita/Sources/Load.php
Riga: 1566

Codice: [Seleziona]
Visitatore
Tipo di errore: Database
http://emuleita.altervista.org/index.php?scheduled=task;ts=1584551040
Errore del Database: Incorrect string value: '\xCF\x85\xD1\x82z\xCF...' for column 'data' at row 1


UPDATE smf_admin_info_files
SET data = SUBSTRING('\r\nvar smf_themeInfo = {\r\n 2734: {\r\n name: \'MinDI\',\r\n desc: \'<div align=\"center\"><a href=\"https://smftricks.com\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\"><img src=\"https://smftricks.com/logos/logo.png\" alt=\"\" class=\"bbc_img\" /></a></div><hr />
<div align=\"center\"><strong><span style=\"font-size: 14pt;\" class=\"bbc_size\"><span style=\"color: orange;\" class=\"bbc_color\">MinDI </span>- Fully Responsive Theme</span></strong>
<span style=\"font-size: 8pt;\" class=\"bbc_size\">Design by <a href=\"http://www.simplemachines.org/community/index.php?action=profile;u=312371\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\">buhthc</a>
Theme by <a href=\"https://smftricks.com/index.php?action=profile;u=1\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\">Diego Andrés</a></span>

<img src=\"https://i.imgur.com/QQiaIlz.png\" alt=\"\" width=\"600\" height=\"413\" class=\"bbc_img resized\" />
</div><hr />
<span style=\"font-size: 14pt;\" class=\"bbc_size\"><a href=\"http://demo.smftricks.com\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\">Demo</a></span>

This is a work of <a href=\"https://smftricks.com\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\">SMF Tricks Team</a>.\',\r\n file: \'MinDI.zip\',\r\n author: \'Diego Andrés\'\r\n },\r\n 2941: {\r\n name: \'Ant's Mutant Curve\',\r\n desc: \'This is the monster that evolved from an apparently simple question:
   
<a href=\"https://www.simplemachines.org/community/index.php?P=a21afa3868d633ffc508a4d9a524ae3c&topic=569433.0\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\">Has anyone improved /main_block.png to have transparent rounded edges?</a>

The short version is that it's Curve, but substantially revamped to be responsive everywhere, without relying on any frameworks or libraries that SMF 2.0.x does not call by default.

Like the original Curve it comes with full support for RTL languages. It also has some custom functionality, and minimal use of images.

Do note that the reworking required for this result may mean that not all mods will install without manual editing.

<hr />
<strong>Note: The following information is provided for anyone who is already using 1.0.4.</strong>

The only difference between 1.0.4 and 1.0.5 is that the latter hides the registration button and greeting if registration is disabled.
This fixes a minor bug with the default code in 2.0.x (default code will show register button and register link even if registration is disabled).

If your forum does not have registration disabled, 1.0.4 will be just as good as 1.0.5.
If your forum does have registration disabled, 1.0.5 will prevent some error messages being shown to guests, and in the error log.

If anyone needs a 1.0.4 to 1.0.5 patch, that can be arranged.

<hr />
01/03/2020 - New 1.0.5 zip uploaded. Fix for minor 2.0.x bug (only relevant if registration is disabled).
27/02/2020 - New 1.0.4 zip uploaded. Gremlins critically endangered. WWF Concerned.
26/02/2020 - New 1.0.3 zip uploaded, now with hardly any gremlins!
24/02/2020 - New 1.0.2 zip uploaded, now with fewer gremlins!
23/02/2020 - New 1.0.1 zip uploaded, hopefully sans gremlins.\',\r\n file: \'Ant\\\'s_Mutant_Curve_1.0.5.zip\',\r\n author: \'Antechinus\'\r\n },\r\n 2940: {\r\n name: \'Averus\',\r\n desc: \'Averus is a dark, flat and modern theme.  Perfect for gaming forums or those that just want a dark theme.  Using Font Awesome for the display icons on the front it is a nice simple lightweight theme.

Terms of use :
This theme is free for personal and commercial use. You are allowed to use it in your projects, change it and adapt for your purposes. You are not allowed to remove the authors copyright.

<a href=\"https://forum.bryandeakin.com/index.php?theme=04\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\">>>Live demo<<</a>\',\r\n file: \'averus.zip\',\r\n author: \'Deaks\'\r\n },\r\n 2939: {\r\n name: \'Vintage XMas\',\r\n desc: \'Vintage Xmas is a simple flat theme that uses css over images where possible, with a unique font and a pleasing layout its a theme for your 2020 Yuletide season.  While the theme does use some CSS3 its designed for minimal impact so will look almost as good if you use an outdated system.

Terms of use :

This theme is free for personal and commercial use. You are allowed to use it in your projects, change it and adapt for your purposes. You are not allowed to remove the authors copyright.

<a href=\"https://forum.bryandeakin.com/index.php?theme=03\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\">>>Live demo<<</a>\',\r\n file: \'vintage.zip\',\r\n author: \'Deaks\'\r\n },\r\n 2082: {\r\n name: \'DaY Relax Theme\',\r\n desc: \'<em>Day Relax Theme , is my first design.
only for <strong>SMF RC3</strong></em>

Free status icons by  <a href=\"http://icontexto.blogspot.com/2008/04/icontexto-webdev.html\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\">IconTexto WebDev</a>

----

<a href=\"http://www.skinmod.eu/themedemo/index.html\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\"><strong>Live demo</strong></a> | <a href=\"http://www.skinmod.eu/\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\"><strong>Support</strong></a> | <a href=\"https://www.paypal.com/pe/cgi-bin/webscr?cmd=_flow&SESSION=3g6Y-E0QLrDomy01r10fanH5hHRpDc1-9ue6zrqbVdZJb6YeXq8-RTyHgbG&dispatch=5885d80a13c0db1f8e263663d3faee8df1d2b5c147af55b8d54f2944c97d2a2a\" class=\"bbc_link\" target=\"_blank\" rel=\"noopener noreferrer\"><strong>Donate to my work</strong></a>
<hr />
<strong>Tested in:</strong>
IE7, Mozilla, Opera, Chrome, Safari

<hr />\',\r\n file: \'Day_relaxrc3.zip\',\r\n author: \'zυтzυ\'\r\n }\r\n};\r\nvar smf_featured = 2734;\r\nvar smf_random = 2082;\r\nvar smf_latestThemes = [2941, 2940, 2939];\r\nfunction smf_themesMoreInfo(id)\r\n{\r\n window.smfLatestThemes_temp = document.getElementById(\"smfLatestThemesWindow\").innerHTML;\r\n\r\n // !!! Why not just always auto?\r\n document.getElementById(\"smfLatestThemesWindow\").style.overflow = \"auto\";\r\n setInnerHTML(document.getElementById(\"smfLatestThemesWindow\"),\r\n \'\\\r\n <h3 style=\"margin: 0; padding: 4px;\">\' + smf_themeInfo[id].name + \'</h3>\\\r\n <h4 style=\"margin: 0;padding: 4px;\"><a href=\"https://custom.simplemachines.org/themes/index.php?lemma=\' + id + \'\">View Theme Now!</a></h4>\\\r\n <div style=\"overflow: auto;\">\\\r\n <img src=\"https://custom.simplemachines.org/themes/index.php?action=download;lemma=\'+id+\';image=thumb\" alt=\"\" style=\"float: right; margin: 10px;\" />\\\r\n <div style=\"padding:8px;\">\' + smf_themeInfo[id].desc.replace(/<a href/g, \'<a href\') + \'</div>\\\r\n </div>\\\r\n <div style=\"padding: 4px;\" class=\"smalltext\"><a href=\"javascript:smf_themesBack();void(0);\">(go back)</a></div>\');\r\n}\r\n\r\nfunction smf_themesBack()\r\n{\r\n document.getElementById(\"smfLatestThemesWindow\").style.overflow = \"\";\r\n setInnerHTML(document.getElementById(\"smfLatestThemesWindow\"), window.smfLatestThemes_temp);\r\n window.scrollTo(0, findTop(document.getElementById(\"smfLatestThemesWindow\")) - 10);\r\n}\r\n\r\nwindow.smfLatestThemes = \'\\\r\n <div id=\"smfLatestThemesWindow\">\\\r\n <div>\\\r\n <img src=\"https://www.simplemachines.org/smf/images/themes.png\" width=\"102\" height=\"98\" style=\"float: right; margin: 0 0 10px 10px;\" alt=\"(package)\" />\\\r\n <ul style=\"list-style: none; padding: 0; margin: 0 0 0 5px;\">\';\r\nfor(var i=0; i < smf_latestThemes.length; i++)\r\n{\r\n var id_theme = smf_latestThemes[i];\r\n window.smfLatestThemes += \'\\\r\n <li style=\"list-style: none;\"><a href=\"javascript:smf_themesMoreInfo(\' + id_theme + \');void(0);\">\' + smf_themeInfo[id_theme].name + \' by \' + smf_themeInfo[id_theme].author + \'</a></li>\';\r\n}\r\n\r\nwindow.smfLatestThemes += \'\\\r\n </ul>\';\r\nif ( smf_featured !=0 || smf_random != 0 )\r\n{\r\n\r\n if ( smf_featured != 0 )\r\n window.smfLatestThemes += \'\\\r\n <h4 style=\"padding: 4px 4px 0 4px; margin: 0;\">Featured Theme</h4>\\\r\n <p style=\"padding: 0 4px; margin: 0;\">\\\r\n <a href=\"javascript:smf_themesMoreInfo(\'+smf_featured+\');void(0);\">\'+smf_themeInfo[smf_featured].name + \' by \' + smf_themeInfo[smf_featured].author+\'</a>\\\r\n </p>\';\r\n if ( smf_random != 0 )\r\n window.smfLatestThemes += \'\\\r\n <h4 style=\"padding: 4px 4px 0 4px;margin: 0;\">Theme of the Moment</h4>\\\r\n <p style=\"padding: 0 4px; margin: 0;\">\\\r\n <a href=\"javascript:smf_themesMoreInfo(\'+smf_random+\');void(0);\">\'+smf_themeInfo[smf_random].name + \' by \' + smf_themeInfo[smf_random].author+\'</a>\\\r\n </p>\';\r\n}\r\nwindow.smfLatestThemes += \'\\\r\n </div>\\\r\n </div>\';\r\n\r\nfunction findTop(el)\r\n{\r\n if (typeof(el.tagName) == \"undefined\")\r\n return 0;\r\n\r\n var skipMe = in_array(el.tagName.toLowerCase(), el.parentNode ? [\"tr\", \"tbody\", \"form\"] : []);\r\n var coordsParent = el.parentNode ? \"parentNode\" : \"offsetParent\";\r\n\r\n if (el[coordsParent] == null || typeof(el[coordsParent].offsetTop) == \"undefined\")\r\n return skipMe ? 0 : el.offsetTop;\r\n else\r\n return (skipMe ? 0 : el.offsetTop) + findTop(el[coordsParent]);\r\n}\r\n\r\nfunction in_array(item, array)\r\n{\r\n for (var i in array)\r\n {\r\n if (array[i] == item)\r\n return true;\r\n }\r\n\r\n return false;\r\n}', 1, 65534)
WHERE id_file = 7
File: /membri/emuleita/Sources/ScheduledTasks.php
Riga: 1311

Poi stamattina, sul forum principale, ho notato questi errori:

Codice: [Seleziona]
Visitatore
Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: character_set
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 1221


Visitatore
Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: utf8
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 1266


Visitatore
Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: utf8
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 1264


Visitatore
Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: character_set
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 1221


Visitatore
Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: server
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 629


Visitatore
Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: character_set
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 1221


Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: utf8
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 1266


Visitatore
Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: utf8
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 1264


Visitatore
Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: character_set
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 1221


Visitatore
Tipo di errore: Indefinito
http://emuleitalia.eu/index.php?scheduled=task;ts=1584489600
8: Undefined index: server
File: /home1/emuleita/public_html/Sources/Subs-Post.php
Riga: 629

Tutti questi si sono verificati alle 01:02:03





Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Giovedì, 19 Marzo 2020 13:58
Se hai un sito di test a cui posso accedere via ftp posso provare a dargli un'occhiata, basta che vi sia il codice e che il forum funzioni (quindi settings e almeno una board), i dati in sé non mi servono.
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Giovedì, 19 Marzo 2020 14:04
Ti ho appena inviato un mp con i dati

Grazie mille
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Giovedì, 19 Marzo 2020 16:37
E' sempre il solito casino con gli encoding.
Onestamente non so se hai o avevi il forum in "non-UTF8", adesso hai $db_character_set = 'utf8'; hai installato sia l'italiano "normal" sia quello UTF8 (oltre a tutti gli altri linguaggi installati con lo stesso problema).

Quindi:
1. verifica se il db è effettivamente UTF8 (encoding di colonne, tabelle e collation del database),
2. rimuovi tutti i file di lingua che non siano nell'encoding corretto (i.e. se il db è UTF8 rimuovi tutti quelli che non lo sono)
3. se il db non è UTF8 rimuovi $db_character_set = 'utf8'; da Settings.php
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Venerdì, 20 Marzo 2020 14:11
Grazie mille Emanuele, solo che non ho risolto nulla... Magari ho sbagliato qualche passaggio, non so.
Ti spiego cosa ho fatto...
Allora ho controllato il DB e sembra che sia in utf8, come puoi vedere dall'immagine
(https://i.postimg.cc/q6r76zdZ/Screen-Shot-03-20-20-at-02-07-PM.png) (https://postimg.cc/q6r76zdZ)

Citazione
2. rimuovi tutti i file di lingua che non siano nell'encoding corretto (i.e. se il db è UTF8 rimuovi tutti quelli che non lo sono)
Li ho toltie, non vedendo migliorie, ho cancellato anche i file della lingua inglese e l'ho reinstallata, ma questa volta la utf8 e il problema è sempre presente.

Citazione
3. se il db non è UTF8 rimuovi $db_character_set = 'utf8'; da Settings.php
Fatto anche questo è come risultato è che non si vede nemmeno la home del forum.

Ovviamente tutto questo l'ho effettuato sul forum di test, non sul principale ;)
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Sabato, 21 Marzo 2020 16:40
Grazie mille Emanuele, solo che non ho risolto nulla...
Beh, non ho mica detto che risolvevi con "solo" quello, ti ho solo detto che quelli sono i passaggi da controllare per primi.

Detto ciò:
Allora ho controllato il DB e sembra che sia in utf8, come puoi vedere dall'immagine
(https://i.postimg.cc/q6r76zdZ/Screen-Shot-03-20-20-at-02-07-PM.png) (https://postimg.cc/q6r76zdZ)
Quello che hai controllato nell'immagine è la collation, come ho scritto sopra:effettivamente UTF8.
Quindi:
1. verifica se il db è effettivamente UTF8 (encoding di colonne, tabelle e collation del database),
controlla che anche l'encoding di tabelle e colonne sia UTF8. Se non lo è, fermati e non convertirlo da phpmyadmin, perché significa che probabilmente c'è stato qualche problema qua e là, quindi la soluzione è tornare a "non-UTF8" e poi tramite il tool in SMF convertire in UTF8.

Citazione
3. se il db non è UTF8 rimuovi $db_character_set = 'utf8'; da Settings.php
Fatto anche questo è come risultato è che non si vede nemmeno la home del forum.
Certo, come ho scritto nella parte che hai quotato, ti ho detto di farlo se il db non è UTF8, come hai scritto tu sopra, la collation è UTF8, quindi quello non va tolto.

Dopo aver controllato sopra, se tutto il resto è UTF8, controlla nella tabella smf_settings il valore della variabile "global_character_set". Questa deve valere UTF8 se tutto è UTF8, altrimenti significa (ancora) che la conversione non è stata portata a termine correttamente e quindi sei in uno stato "confusionario" che bisognerà sistemare.

Quanto odio mysql e i suoi charset.
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Sabato, 21 Marzo 2020 19:28
Se ho capito bene ed ho guardato nei posti giusti, posso dirti che c'è un mix delle codifiche, come puoi vedere dalle immagini di esempio:
(https://i.postimg.cc/dDywcvP7/tab1.png) (https://postimg.cc/dDywcvP7) (https://i.postimg.cc/yDvzy89G/tab2.png) (https://postimg.cc/yDvzy89G)

Ho anche controllato nella tabella smf_setting e il risultaot è questo:
(https://i.postimg.cc/GTxqk9Ng/tab3.png) (https://postimg.cc/GTxqk9Ng)

 ???
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Domenica, 22 Marzo 2020 13:40
Tabella smf_messages?
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Domenica, 22 Marzo 2020 13:52
latin1_swedish_ci   

(https://i.postimg.cc/sv37smMg/tab4.png) (https://postimg.cc/sv37smMg)
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Domenica, 22 Marzo 2020 14:30
Allora, sei in latin_swedish e non UTF8, quindi:
1) rimuovi tutti file di lingua UTF8 e metti quelli non-UTF8,
2) rimuovi dalla tabella smf_settings la voce "global_character_set" (o impostalo a vuoto),
3) rimuovi $db_character_set = 'utf8'; da Settings.php

In teoria questo dovrebbe aiutare a ripristinare uno stato "corretto".
Se questo ti permette di accedere a SMF, consiglio di eseguire la conversione a UTF8 da SMF e poi re-installare le lingue corrette (dopo aver rimosso quelle sbagliate).
Ad essere onesto, siccome sei sul forum di prova, lascia solo l'inglese non-utf8 che fai prima...
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Domenica, 22 Marzo 2020 15:33
Fatto tutto e, come risultato, pagina bianca anche all'indice adesso ;D
Fortunatamente è il forum di test

Reinstallo il tutto o ci sono altre strade ?
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Martedì, 24 Marzo 2020 08:23
Lascia dove si trova, appena ho un minuto guardo.
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Domenica, 29 Marzo 2020 14:09
1) non avevi cambiato il valore di 'global_character_set' nella tabella smf_settings,
2) probabilmente parecchie stringhe mancano, ad esempio $txt['gpdr_privacypolicy'] non esiste e fallisce un preg_replace in ob_sessrewrite e quindi l'output diventa vuoto.

Per 1 l'ho corretto.
Per 2, ho ci ho girato in giro per quella stringa in particolare cambiando:
Codice: [Seleziona]
if (!empty($modSettings['gpdr_enable_privacy_policy']))
{
global $txt;
$buffer = preg_replace('~(, Simple Machines LLC</a>)~', ', Simple Machines LLC</a><br /><a href="' . $scripturl . '?action=gpdr;sa=privacypolicy">' . $txt['gpdr_privacypolicy'] . '</a>', $buffer);
$buffer = preg_replace('~(class="new_win">Simple Machines</a>)~', 'class="new_win">Simple Machines</a><br /><a href="' . $scripturl . '?action=gpdr;sa=privacypolicy">' . $txt['gpdr_privacypolicy'] . '</a>', $buffer);
}
in:
Codice: [Seleziona]
if (!empty($modSettings['gpdr_enable_privacy_policy']))
{
global $txt;
$buffer = preg_replace('~(, Simple Machines LLC</a>)~', ', Simple Machines LLC</a><br /><a href="' . $scripturl . '?action=gpdr;sa=privacypolicy">' . (isset($txt['gpdr_privacypolicy']) ? $txt['gpdr_privacypolicy'] : 'Provacy Policy') . '</a>', $buffer);
$buffer = preg_replace('~(class="new_win">Simple Machines</a>)~', 'class="new_win">Simple Machines</a><br /><a href="' . $scripturl . '?action=gpdr;sa=privacypolicy">' . (isset($txt['gpdr_privacypolicy']) ? $txt['gpdr_privacypolicy'] : 'Provacy Policy') . '</a>', $buffer);
}

nel file QueryString.php, però non è una soluzione, solo un workaround per dimostrare che il forum funziona (se tutto è corretto).
Ora a te il ripristinare tutte le stringhe di testo mancanti e ripetere il tutto live.
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Domenica, 29 Marzo 2020 14:50
Grazie mille Emauele, in effetti ora il forum è ritornato visibile, solo che ci sono delle cose che non vanno...
Solo a loggarmi e girare qualche pagina si sono generati circa 200 pagine di errori nel registro, tantissime ce ne sono di ieri e, in totale, sono circa 1300 pagine. Ti faccio degli screen degli errori giusto per farti fare un idea
(https://i.postimg.cc/mhHpZj1z/Screen-Shot-03-29-20-at-02-47-PM.png) (https://postimg.cc/mhHpZj1z) (https://i.postimg.cc/WdnHL4F5/Screen-Shot-03-29-20-at-02-47-PM-001.png) (https://postimg.cc/WdnHL4F5) (https://i.postimg.cc/tsXB5HSW/Screen-Shot-03-29-20-at-02-49-PM.png) (https://postimg.cc/tsXB5HSW)

Poi una delucidazione su questo tuo passaggio:
Ora a te il ripristinare tutte le stringhe di testo mancanti e ripetere il tutto live.

Col ripristinare le stringhe vuoi dire di istallare daccapo la lingua Ita utf8, vero ?

Grazie
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Domenica, 29 Marzo 2020 15:58
Quelli sono tutti undefined di stringhe di lingua mancanti.
Perché mancano? Perché probabilmente nel cancellare tutto dalla directory della lingua per rirpristinare i file in inglese originali hai cancellato anche i file dei mod.

Col ripristinare le stringhe vuoi dire di istallare daccapo la lingua Ita utf8, vero ?
SCORDATI IL FOT***O UTF8! :D

Il tuo forum è configurato per usare l'ISO 8859-whatever e collation latin_swedish. Quindi usi questi, non UTF8.
Se vuoi usare UTF8, prima fai la conversione dal pannello di admin di SMF (che sistema tutto il database e i "dettagli"), poi inizi a installare i file di lingua UTF8 e aggiungere tutte le stringhe dei mod ai file UTF8.

Premesso che convertire ad UTF8 sarebbe solo cosa buona e giusta nel 2020, devi decidere tu cosa fare e quando. Se decidi per UTF8i però,, fallo nella sequenza corretta e non installando pacchetti di lingua "a caso".
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Domenica, 29 Marzo 2020 17:07
Ok ;D
Allora gli errori sono diminuiti ad una ventina ad ogni caricamento pagina e va bene. Ora il problema è un altro.
Quando voglio convertire il DB in utf8 trovo questo messaggio:
Your messages table is using a fulltext index for use when searching. You cannot proceed in converting to UTF-8 until that index is removed. You can re-create it after the conversion has been completed.

Come lo risolvo ?
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: radu81 - Domenica, 29 Marzo 2020 23:05
te lo dice come risolvere: cancella l'index di ricerca prima di iniziare la conversione, dopo vai a creare un nuovo indice di ricerca, (Admin > Forum > Ricerca > Metodo di ricerca)
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Lunedì, 30 Marzo 2020 11:45
Grazie Radu, sono riuscito a fare la conversione del DB a utf8. Poi ho installato la lingua utf8 e il forum è ritornato allo stato iniziale, ovvero pagine bianche se non si è loggati :-[ :-[ :-[
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Domenica, 12 Aprile 2020 13:20
Metti la lingua per i visitatori a inglese.
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Lunedì, 13 Aprile 2020 10:18
Giorni fa ho rimosso di nuovo la lingua ita e non è cambiato nulla :(
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Sabato, 02 Maggio 2020 18:09
Niente, sono 3 giorni che ci provo e non riesco a risolvere, sempre peggio. Purtroppo le operazioni da fare superano la mia soglia di conoscenza del settore :(
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: emanuele - Mercoledì, 06 Maggio 2020 18:35
Vediamo se nel fine settimana riesco a perderci qualche momento.
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Martedì, 24 Novembre 2020 10:36
Vi aggiorno sulla situazione...
Anche se non in modo costante, in questo periodo ho sempre cercato di risolvere il problema, ovviamente non riuscendoci viste le mie limitate conoscenze a livello database. Ieri però, grazie a Belfa, il forum è ritornato a funzionare regolarmente facendo un downgrade dalla 2.0.17 alla 2.0.15 e nel frattempo ho capito che lo scombussolamento era dovuto alla 2.0.16...
Chissà se con la futura 2.0.18, se ci sarà, questo problema scompare ???
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Venerdì, 19 Febbraio 2021 23:40
Anche se a malincuore, ritorno in questo topic :'(
Col rilascio della 2.0.18 mi ci sono dedicato ed ho fatto tutto; il DB è tutto in utf8, cancellato le lingue rimanendo solo l'inglese e cancellato i residui delle vecchie installazione delle lingue ita, aggiornato fino alla 2.0.18, reinstallato la ita utf8 ed il problema persiste :-\
Vi andrebbe di sfidare questo problema ? ;D

Grazie anticipatamente
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Flavio93Zena - Sabato, 20 Febbraio 2021 01:07
Non so se son scemo io o qualcosa non mi è chiaro ma quel forum (emuleitalia) non è 2.0.18 e da visitatore mi funziona tutto, ho provato oltre 10 sezioni...

E decisamente non è UTF8 a giudicare dal "?" nel linktree, il content-type lo è ma non il contenuto.
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Sabato, 20 Febbraio 2021 08:54
Si Flavio, scusami ma ieri ho dimenticato di dire che sto lavorando sullo spazio per i test su altervista. Il link è questo http://emuleita.altervista.org/index.php
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Mercoledì, 24 Febbraio 2021 21:15
Ho fatto ulteriori prove e sono qui per restringervi il campo :P
Allora, io uso come tema predefinito il tema epic, visionabile qui, (https://custom.simplemachines.org/themes/index.php?lemma=2332) ed h oil problema. Mentre, se cambio tema a quello di default, o un altro che ho installato, il problema scompare, ovvero il forum torna visibile anche all'interno e non solo nella home.

Cosa e dove dovrei modificare per aggiustare tutto ?

Grazie
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Tanaka - Lunedì, 01 Marzo 2021 08:48
Scusa, ma è normale che le url a cui puntano i link siano .html ?
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Lunedì, 01 Marzo 2021 08:50
Non credo, forse ho fatto qualcosa senza rendermene conto ???
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Flavio93Zena - Lunedì, 01 Marzo 2021 19:50
Una pagina bianca è un errore di sintassi di php, quindi non viene registrato nel log di SMF.
Dubito che su altervista hai accesso al log degli errori del server, quindi prova a mettere queste righe in index.php:
Codice: [Seleziona]
error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);
direi all'inizio, appena dopo <?php
Questo l'avevi fatto poi? Perchè pagina bianca totale mi dice tutto e nulla :( Mi dice che non funziona una fava, ma anche nulla riguardo al problema.

Interessante che http://emuleita.altervista.org/index.php?action=credits questa funzioni.

EDIT: nella sezione head del forum vedo ancora utf-8, per cui non hai effettuato la procedura suggerita da emanuele.
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Martedì, 02 Marzo 2021 14:39
Certo che inserii quel codice nell'index, solo che non portò a nulla di che.
Riguardo all'utf8, sono sicuro che tutto il db e le collation sono in utf8, la lingua l'ho installata secondo la procedura corretta, solo che non capisco è perchè col tema epic non funziona e tutti gli altri temi non ci sono problemi ??? ???
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Flavio93Zena - Martedì, 02 Marzo 2021 18:36
Qualche cosa nel registro errori del server? Perchè senza siamo ad un punto morto, se hai effettuato la conversione dal pannello di smf ed è tutto in utf8 non c'è tecnicamente ragione per la quale non dovrebbe funzionare, eppure... Quindi serve il registro per vedere se ha qualcosa lì :/
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Martedì, 02 Marzo 2021 22:11
C'è modo di avere ste info su altervista ? Dal mio pannello non c'è nulla al riguardo :(
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Flavio93Zena - Mercoledì, 03 Marzo 2021 00:28
Non che io sappia, altervista lo tengo giusto per i forum di test infatti... Dicono che non sia possibile ma io i log li ho su server condivisi...
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Lucarella - Mercoledì, 03 Marzo 2021 11:41
Visto che il  problema sembra essere il tema, esiste qualche procedura particolare per adattare tutti i mod ad un altro tema, installato o da installare, senza doverli togliere e rimetterli ?
Titolo: Re:Pagine bianche in tutto il forum
Inserito da: Flavio93Zena - Mercoledì, 03 Marzo 2021 16:45
No purtroppo. Togliere e rimettere tutti quelli che hanno effettuato modifiche nei file presenti sul tema stesso... Per esempio se una mod modifica il file profile.template.php ma il tema che vuoi installare non lo ha, non avrai bisogno di reinstallarla perchè significa che utilizza il template di default con css diverso per quell'area :)

Al contrario se una mod modifica il file index.template.php al 99% dovrai reinstallarla perchè quel file è presente in tutti i temi modificati da me visti finora ;D
SimplePortal 2.3.7 © 2008-2018, SimplePortal