Autore Topic: Pagine bianche in tutto il forum  (Letto 2776 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5076
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Pagine bianche in tutto il forum
« Risposta #15 il: Domenica, 22 Marzo 2020 14:30 »
Allora, sei in latin_swedish e non UTF8, quindi:
1) rimuovi tutti file di lingua UTF8 e metti quelli non-UTF8,
2) rimuovi dalla tabella smf_settings la voce "global_character_set" (o impostalo a vuoto),
3) rimuovi $db_character_set = 'utf8'; da Settings.php

In teoria questo dovrebbe aiutare a ripristinare uno stato "corretto".
Se questo ti permette di accedere a SMF, consiglio di eseguire la conversione a UTF8 da SMF e poi re-installare le lingue corrette (dopo aver rimosso quelle sbagliate).
Ad essere onesto, siccome sei sul forum di prova, lascia solo l'inglese non-utf8 che fai prima...

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 455
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #16 il: Domenica, 22 Marzo 2020 15:33 »
Fatto tutto e, come risultato, pagina bianca anche all'indice adesso ;D
Fortunatamente è il forum di test

Reinstallo il tutto o ci sono altre strade ?
« Ultima modifica: Mercoledì, 25 Marzo 2020 08:28 da Lucarella »

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5076
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Pagine bianche in tutto il forum
« Risposta #17 il: Martedì, 24 Marzo 2020 08:23 »
Lascia dove si trova, appena ho un minuto guardo.

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5076
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Pagine bianche in tutto il forum
« Risposta #18 il: Domenica, 29 Marzo 2020 14:09 »
1) non avevi cambiato il valore di 'global_character_set' nella tabella smf_settings,
2) probabilmente parecchie stringhe mancano, ad esempio $txt['gpdr_privacypolicy'] non esiste e fallisce un preg_replace in ob_sessrewrite e quindi l'output diventa vuoto.

Per 1 l'ho corretto.
Per 2, ho ci ho girato in giro per quella stringa in particolare cambiando:
Codice: [Seleziona]
if (!empty($modSettings['gpdr_enable_privacy_policy']))
{
global $txt;
$buffer = preg_replace('~(, Simple Machines LLC</a>)~', ', Simple Machines LLC</a><br /><a href="' . $scripturl . '?action=gpdr;sa=privacypolicy">' . $txt['gpdr_privacypolicy'] . '</a>', $buffer);
$buffer = preg_replace('~(class="new_win">Simple Machines</a>)~', 'class="new_win">Simple Machines</a><br /><a href="' . $scripturl . '?action=gpdr;sa=privacypolicy">' . $txt['gpdr_privacypolicy'] . '</a>', $buffer);
}
in:
Codice: [Seleziona]
if (!empty($modSettings['gpdr_enable_privacy_policy']))
{
global $txt;
$buffer = preg_replace('~(, Simple Machines LLC</a>)~', ', Simple Machines LLC</a><br /><a href="' . $scripturl . '?action=gpdr;sa=privacypolicy">' . (isset($txt['gpdr_privacypolicy']) ? $txt['gpdr_privacypolicy'] : 'Provacy Policy') . '</a>', $buffer);
$buffer = preg_replace('~(class="new_win">Simple Machines</a>)~', 'class="new_win">Simple Machines</a><br /><a href="' . $scripturl . '?action=gpdr;sa=privacypolicy">' . (isset($txt['gpdr_privacypolicy']) ? $txt['gpdr_privacypolicy'] : 'Provacy Policy') . '</a>', $buffer);
}

nel file QueryString.php, però non è una soluzione, solo un workaround per dimostrare che il forum funziona (se tutto è corretto).
Ora a te il ripristinare tutte le stringhe di testo mancanti e ripetere il tutto live.

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 455
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #19 il: Domenica, 29 Marzo 2020 14:50 »
Grazie mille Emauele, in effetti ora il forum è ritornato visibile, solo che ci sono delle cose che non vanno...
Solo a loggarmi e girare qualche pagina si sono generati circa 200 pagine di errori nel registro, tantissime ce ne sono di ieri e, in totale, sono circa 1300 pagine. Ti faccio degli screen degli errori giusto per farti fare un idea


Poi una delucidazione su questo tuo passaggio:
Ora a te il ripristinare tutte le stringhe di testo mancanti e ripetere il tutto live.

Col ripristinare le stringhe vuoi dire di istallare daccapo la lingua Ita utf8, vero ?

Grazie

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5076
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Pagine bianche in tutto il forum
« Risposta #20 il: Domenica, 29 Marzo 2020 15:58 »
Quelli sono tutti undefined di stringhe di lingua mancanti.
Perché mancano? Perché probabilmente nel cancellare tutto dalla directory della lingua per rirpristinare i file in inglese originali hai cancellato anche i file dei mod.

Col ripristinare le stringhe vuoi dire di istallare daccapo la lingua Ita utf8, vero ?
SCORDATI IL FOT***O UTF8! :D

Il tuo forum è configurato per usare l'ISO 8859-whatever e collation latin_swedish. Quindi usi questi, non UTF8.
Se vuoi usare UTF8, prima fai la conversione dal pannello di admin di SMF (che sistema tutto il database e i "dettagli"), poi inizi a installare i file di lingua UTF8 e aggiungere tutte le stringhe dei mod ai file UTF8.

Premesso che convertire ad UTF8 sarebbe solo cosa buona e giusta nel 2020, devi decidere tu cosa fare e quando. Se decidi per UTF8i però,, fallo nella sequenza corretta e non installando pacchetti di lingua "a caso".

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 455
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #21 il: Domenica, 29 Marzo 2020 17:07 »
Ok ;D
Allora gli errori sono diminuiti ad una ventina ad ogni caricamento pagina e va bene. Ora il problema è un altro.
Quando voglio convertire il DB in utf8 trovo questo messaggio:
Your messages table is using a fulltext index for use when searching. You cannot proceed in converting to UTF-8 until that index is removed. You can re-create it after the conversion has been completed.

Come lo risolvo ?

Offline radu81

  • Staff IS
  • *******
  • Post: 412
  • Sesso: Maschio
    • Mostra profilo
  • Versione SMF: -
  • Versione ElkArte: 1.1.x
Re:Pagine bianche in tutto il forum
« Risposta #22 il: Domenica, 29 Marzo 2020 23:05 »
te lo dice come risolvere: cancella l'index di ricerca prima di iniziare la conversione, dopo vai a creare un nuovo indice di ricerca, (Admin > Forum > Ricerca > Metodo di ricerca)

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 455
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #23 il: Lunedì, 30 Marzo 2020 11:45 »
Grazie Radu, sono riuscito a fare la conversione del DB a utf8. Poi ho installato la lingua utf8 e il forum è ritornato allo stato iniziale, ovvero pagine bianche se non si è loggati :-[ :-[ :-[

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5076
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Pagine bianche in tutto il forum
« Risposta #24 il: Domenica, 12 Aprile 2020 13:20 »
Metti la lingua per i visitatori a inglese.

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 455
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #25 il: Lunedì, 13 Aprile 2020 10:18 »
Giorni fa ho rimosso di nuovo la lingua ita e non è cambiato nulla :(

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 455
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #26 il: Sabato, 02 Maggio 2020 18:09 »
Niente, sono 3 giorni che ci provo e non riesco a risolvere, sempre peggio. Purtroppo le operazioni da fare superano la mia soglia di conoscenza del settore :(

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5076
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Pagine bianche in tutto il forum
« Risposta #27 il: Mercoledì, 06 Maggio 2020 18:35 »
Vediamo se nel fine settimana riesco a perderci qualche momento.

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 455
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #28 il: Martedì, 24 Novembre 2020 10:36 »
Vi aggiorno sulla situazione...
Anche se non in modo costante, in questo periodo ho sempre cercato di risolvere il problema, ovviamente non riuscendoci viste le mie limitate conoscenze a livello database. Ieri però, grazie a Belfa, il forum è ritornato a funzionare regolarmente facendo un downgrade dalla 2.0.17 alla 2.0.15 e nel frattempo ho capito che lo scombussolamento era dovuto alla 2.0.16...
Chissà se con la futura 2.0.18, se ci sarà, questo problema scompare ???

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 455
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #29 il: Venerdì, 19 Febbraio 2021 23:40 »
Anche se a malincuore, ritorno in questo topic :'(
Col rilascio della 2.0.18 mi ci sono dedicato ed ho fatto tutto; il DB è tutto in utf8, cancellato le lingue rimanendo solo l'inglese e cancellato i residui delle vecchie installazione delle lingue ita, aggiornato fino alla 2.0.18, reinstallato la ita utf8 ed il problema persiste :-\
Vi andrebbe di sfidare questo problema ? ;D

Grazie anticipatamente

 

News in tutte le pagine del forum

Aperto da BELFASezione SMF 2.0

Risposte: 7
Visite: 2110
Ultimo post Martedì, 22 Luglio 2014 11:57
da BELFA
Nascondersi a tutto il forum

Aperto da pierpisSezione SMF 2.0

Risposte: 4
Visite: 950
Ultimo post Venerdì, 01 Agosto 2014 22:56
da emanuele
Aggiornamento del Forum SMF

Aperto da DarknicoSezione Guide - Trucchi

Risposte: 0
Visite: 6576
Ultimo post Sabato, 09 Febbraio 2013 14:32
da Darknico
SimplePortal 2.3.7 © 2008-2018, SimplePortal