Autore Topic: Pagine bianche in tutto il forum  (Letto 2675 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Online Flavio93Zena

  • Staff IS
  • *******
  • Post: 3131
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #30 il: Sabato, 20 Febbraio 2021 01:07 »
Non so se son scemo io o qualcosa non mi Ŕ chiaro ma quel forum (emuleitalia) non Ŕ 2.0.18 e da visitatore mi funziona tutto, ho provato oltre 10 sezioni...

E decisamente non Ŕ UTF8 a giudicare dal "?" nel linktree, il content-type lo Ŕ ma non il contenuto.
« Ultima modifica: Sabato, 20 Febbraio 2021 01:09 da Flavio93Zena »

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 448
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #31 il: Sabato, 20 Febbraio 2021 08:54 »
Si Flavio, scusami ma ieri ho dimenticato di dire che sto lavorando sullo spazio per i test su altervista. Il link Ŕ questo http://emuleita.altervista.org/index.php

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 448
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #32 il: Mercoledý, 24 Febbraio 2021 21:15 »
Ho fatto ulteriori prove e sono qui per restringervi il campo :P
Allora, io uso come tema predefinito il tema epic, visionabile qui, ed h oil problema. Mentre, se cambio tema a quello di default, o un altro che ho installato, il problema scompare, ovvero il forum torna visibile anche all'interno e non solo nella home.

Cosa e dove dovrei modificare per aggiustare tutto ?

Grazie

Offline Tanaka

  • Utente IS Lv.2
  • **
  • Post: 205
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #33 il: Lunedý, 01 Marzo 2021 08:48 »
Scusa, ma Ŕ normale che le url a cui puntano i link siano .html ?

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 448
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #34 il: Lunedý, 01 Marzo 2021 08:50 »
Non credo, forse ho fatto qualcosa senza rendermene conto ???

Online Flavio93Zena

  • Staff IS
  • *******
  • Post: 3131
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #35 il: Lunedý, 01 Marzo 2021 19:50 »
Una pagina bianca Ŕ un errore di sintassi di php, quindi non viene registrato nel log di SMF.
Dubito che su altervista hai accesso al log degli errori del server, quindi prova a mettere queste righe in index.php:
Codice: [Seleziona]
error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);
direi all'inizio, appena dopo <?php
Questo l'avevi fatto poi? PerchŔ pagina bianca totale mi dice tutto e nulla :( Mi dice che non funziona una fava, ma anche nulla riguardo al problema.

Interessante che http://emuleita.altervista.org/index.php?action=credits questa funzioni.

EDIT: nella sezione head del forum vedo ancora utf-8, per cui non hai effettuato la procedura suggerita da emanuele.
« Ultima modifica: Lunedý, 01 Marzo 2021 23:24 da Flavio93Zena »

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 448
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #36 il: Martedý, 02 Marzo 2021 14:39 »
Certo che inserii quel codice nell'index, solo che non port˛ a nulla di che.
Riguardo all'utf8, sono sicuro che tutto il db e le collation sono in utf8, la lingua l'ho installata secondo la procedura corretta, solo che non capisco Ŕ perchŔ col tema epic non funziona e tutti gli altri temi non ci sono problemi ??? ???

Online Flavio93Zena

  • Staff IS
  • *******
  • Post: 3131
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #37 il: Martedý, 02 Marzo 2021 18:36 »
Qualche cosa nel registro errori del server? PerchŔ senza siamo ad un punto morto, se hai effettuato la conversione dal pannello di smf ed Ŕ tutto in utf8 non c'Ŕ tecnicamente ragione per la quale non dovrebbe funzionare, eppure... Quindi serve il registro per vedere se ha qualcosa lý :/

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 448
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #38 il: Martedý, 02 Marzo 2021 22:11 »
C'Ŕ modo di avere ste info su altervista ? Dal mio pannello non c'Ŕ nulla al riguardo :(

Online Flavio93Zena

  • Staff IS
  • *******
  • Post: 3131
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #39 il: Mercoledý, 03 Marzo 2021 00:28 »
Non che io sappia, altervista lo tengo giusto per i forum di test infatti... Dicono che non sia possibile ma io i log li ho su server condivisi...

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 448
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #40 il: Mercoledý, 03 Marzo 2021 11:41 »
Visto che il  problema sembra essere il tema, esiste qualche procedura particolare per adattare tutti i mod ad un altro tema, installato o da installare, senza doverli togliere e rimetterli ?

Online Flavio93Zena

  • Staff IS
  • *******
  • Post: 3131
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Pagine bianche in tutto il forum
« Risposta #41 il: Mercoledý, 03 Marzo 2021 16:45 »
No purtroppo. Togliere e rimettere tutti quelli che hanno effettuato modifiche nei file presenti sul tema stesso... Per esempio se una mod modifica il file profile.template.php ma il tema che vuoi installare non lo ha, non avrai bisogno di reinstallarla perchŔ significa che utilizza il template di default con css diverso per quell'area :)

Al contrario se una mod modifica il file index.template.php al 99% dovrai reinstallarla perchŔ quel file Ŕ presente in tutti i temi modificati da me visti finora ;D

 

News in tutte le pagine del forum

Aperto da BELFASezione SMF 2.0

Risposte: 7
Visite: 2037
Ultimo post Martedý, 22 Luglio 2014 11:57
da BELFA
Nascondersi a tutto il forum

Aperto da pierpisSezione SMF 2.0

Risposte: 4
Visite: 944
Ultimo post Venerdý, 01 Agosto 2014 22:56
da emanuele
Aggiornamento del Forum SMF

Aperto da DarknicoSezione Guide - Trucchi

Risposte: 0
Visite: 6408
Ultimo post Sabato, 09 Febbraio 2013 14:32
da Darknico
SimplePortal 2.3.7 © 2008-2018, SimplePortal