Italian SMF

Supporto SMF => SMF 2.0 => Topic aperto da: wild56 - Lunedì, 04 Maggio 2015 14:34

Titolo: Forum raso al suolo
Inserito da: wild56 - Lunedì, 04 Maggio 2015 14:34
alcuni giorni fa il forum è scomparso. Chieste spiegazioni al provider (Netsons) riferisce che è in corso un attacco DDos ma stanno provvedendo.

Intanto però il forum non torna on line e alla mia richiesta di spiegazioni ulteriori mi rispondono che l'errore 404 deriva dal fatto che non c'è alcun file nella directory. Mi precipito a controllare e in effetti è proprio così: tutto il contenuto è stato cancellato, sia il forum che tre blog.

In un successivo messaggio mi dicono che se per caso ho cancellato "erroneamente" (io???) il forum posso recuperarlo con il backup giornaliero di Risoft. Grazie a quest'ultimo riesco a recuperare la situazione preesistente.
 
Richiedo spiegazioni su come sia potuto accadere che tutto il contenuto del mio dominio sia stato cancellato. Ecco la  risposta:

"Buongiorno,
dai log di sistema non risultano rimozioni avvenute mediante FTP o "cPanel --> Gestione Files", è possibile che la cancellazione sia avvenuta mediante accesso tramite bug del codice da lei in uso, le consigliamo per questo di tenere sempre aggiornata all'ultima versione il/i CMS da lei in uso e di cambiarne le password di accesso al backend.
Resto a sua disposizione.
Cordiali saluti."

insomma della serie "razzi miei". Ma il forum era aggiornato...  (a parte simpleportal). Cosa può essere successo?
Titolo: Re:Forum raso al suolo
Inserito da: Darknico - Lunedì, 04 Maggio 2015 15:00
Dubito che la colpa sia un bug......SMF non può cancellarsi da solo!
L'attacco ricevuto mi pare più plausibile.... (escludendo che tu stesso non ti sei cancellato i file da solo!)
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Lunedì, 04 Maggio 2015 15:01
Dubito che la colpa sia un bug......SMF non può cancellarsi da solo!
L'attacco ricevuto mi pare più plausibile.... (escludendo che tu stesso non ti sei cancellato i file da solo!)

ma se anche così fosse risulterebbe dai loro logs no?
Titolo: Re:Forum raso al suolo
Inserito da: emanuele - Lunedì, 04 Maggio 2015 15:35
Può essere che fosse il 23 aprile quando è sparito tutto?
Titolo: Re:Forum raso al suolo
Inserito da: Flavio93Zena - Lunedì, 04 Maggio 2015 17:25
Può essere che fosse il 23 aprile quando è sparito tutto?
O hai accesso a informazioni che non ho, oppure non capisco il motivo della domanda...
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Lunedì, 04 Maggio 2015 18:17
no è sucesso il 29. Che è successo il 23???
Titolo: Re:Forum raso al suolo
Inserito da: emanuele - Lunedì, 04 Maggio 2015 19:05
Niente, stavo guardando il file sbagliato.
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Lunedì, 04 Maggio 2015 19:14
il forum è stato rimesso in piedi ma ora iniziano i problemi, l'utente miki non riesce a entrare:

miki: Error 403  We're sorry, but we could not fulfill your request for /gim/paganella-bondone-stivo-monte-baldo/?action=post2;start=0 on this server.  You do not have permission to access this server. Data may not be posted from offsite forms.  Your technical support key is: 5b51-20c3-cd36-1abb  You can use this key to fix this problem yourself.  If you are unable to fix the problem yourself, please contact the WEBMA5TER and be sure to provide the technical support key shown above.
Titolo: Re:Forum raso al suolo
Inserito da: radu81 - Lunedì, 04 Maggio 2015 21:21
Quello mi sembra un messaggio dalla mod HTTPBL.
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Lunedì, 04 Maggio 2015 21:23
eccone un altro, non riesco a rispondere appare un messaggio "sessione scaduta" anche se la risposta avviene dopo pochi secondi :(

Titolo: Re:Forum raso al suolo
Inserito da: emanuele - Lunedì, 04 Maggio 2015 21:28
miki: Error 403  We're sorry, but we could not fulfill your request for /gim/paganella-bondone-stivo-monte-baldo/?action=post2;start=0 on this server.  You do not have permission to access this server. Data may not be posted from offsite forms.  Your technical support key is: 5b51-20c3-cd36-1abb  You can use this key to fix this problem yourself.  If you are unable to fix the problem yourself, please contact the WEBMA5TER and be sure to provide the technical support key shown above.
http://www.girovagandoinmontagna.com/gim/admin/?area=badbehavior;sa=report_denied;%20bbid=4229700
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Lunedì, 04 Maggio 2015 21:32
cosa vuol dire?
Titolo: Re:Forum raso al suolo
Inserito da: emanuele - Lunedì, 04 Maggio 2015 21:45
Che risulta che il suo user agent sia quello dei bot di google.

Ora non chiedere a me il come, ed il perché, questo succeda, non ne ho idea.
Potrebbe essere tapatalk, potrebbe essere un qualche programma che usa lui per postare (magari risponde tramite un feedreader su G+ e quello usa lo user agent di un bot di google, non ne ho la più pallida idea).
Chiedi a lui come ha postato.

L'alternativa credo sia togliere bad behaviour, ma se l'hai messo è perché avevi problemi di spammer.

Per le sessioni può essere qualunque cosa.
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Lunedì, 04 Maggio 2015 21:48
potrebbe essere il mod security?

update: non ho controllato è ancora disattivato...
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Lunedì, 04 Maggio 2015 23:23
Chiedi a lui come ha postato.
L'alternativa credo sia togliere bad behaviour, ma se l'hai messo è perché avevi problemi di spammer.
Per le sessioni può essere qualunque cosa.

ma non capisco se prima il beahviour funzionava perché ora non funziona più.
Riguardo le sessioni, cosa posso fare? Neppure io riesco a rispondere ai messaggi ora... :(
Titolo: Re:Forum raso al suolo
Inserito da: emanuele - Martedì, 05 Maggio 2015 00:28
Prova ora, se non si è capito dai messaggi di test che ho scritto mi sto innervosendo...

ma non capisco se prima il beahviour funzionava perché ora non funziona più.
Miracoli.
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Martedì, 05 Maggio 2015 01:06
ora funziona!!! Come hai fatto? Cos'era? :)
Titolo: Re:Forum raso al suolo
Inserito da: emanuele - Martedì, 05 Maggio 2015 09:15
Ho reindirizzato tutto alla versione non-www.
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Martedì, 05 Maggio 2015 12:53
dio mio, non ce la farò mai :(
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Mercoledì, 06 Maggio 2015 11:19
oggi un forumista... non se ne esce più :(

Citazione
Oggi se digito girovagandoinmontagna.com o .it mi da errore 404 se alla fine aggiungo /gim/forum va.

Titolo: Re:Forum raso al suolo
Inserito da: emanuele - Mercoledì, 06 Maggio 2015 14:15
Corretto.
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Lunedì, 11 Maggio 2015 10:40
Ho reindirizzato tutto alla versione non-www.

perfetto!
Altra domanda: mi sto facendo aiutare anche riguardo al marketing/seo e compagnia bella, mi hanno chiesto:

Citazione
a. verificare quanti erano le url con il www. e quelle senza www, e passare tutti al gruppo che aveva maggior numero di URL già indicizzate.

e fin qui mi pare che ci siamo

Citazione
b. re-indirizzare via HTaccess - 301 le URL che sono state cambiate alle nuove URL.

a questo invece non saprei come rispondere...
Titolo: Re:Forum raso al suolo
Inserito da: Flavio93Zena - Lunedì, 11 Maggio 2015 14:40
Ho idea che lo abbia già fatto emanuele da quel che ha detto... Non ho accesso al tuo htaccess ma una piccola ricerca su google ti direbbe cosa è quella roba lì e ti darebbe la possibilità di confrontare il codice che hai nel file e vedere se emanuele lo ha effettivamente aggiunto (conoscendolo sono piuttosto sicuro di sì).
Titolo: Re:Forum raso al suolo
Inserito da: emanuele - Lunedì, 11 Maggio 2015 16:50
a questo invece non saprei come rispondere...
Dovresti guardare l'htaccess e vedere che c'è
Codice: [Seleziona]
[R=301,L] dopo ogni redirect.
Titolo: Re:Forum raso al suolo
Inserito da: wild56 - Lunedì, 11 Maggio 2015 23:44
ho aperto il file e c'è scritto questo, ma non so cosa significhi esattamente e se risponde alla domanda che mi è stata fatta: "re-indirizzare via HTaccess - 301 le URL che sono state cambiate alle nuove URL."

Codice: [Seleziona]
RewriteEngine on
RewriteBase /
#RewriteCond %{HTTP_HOST} ^(www\.girovagandoinmontagna\.com/gim)(:80)? [NC]
#RewriteRule ^(.*) girovagandoinmontagna.com/gim/$1 [R=301,L]
#RewriteRule ^$ /gim [L]
#RewriteRule ^forums/(.*)$ /gim/$1 [L,R=301]

RewriteCond %{HTTP_HOST} ^grandeguerraintrentino\.it$ [OR]
RewriteCond %{HTTP_HOST} ^www\.grandeguerraintrentino\.it$
RewriteRule ^/?$ "http\:\/\/www\.girovagandoinmontagna\.com\/ggit" [R=301,L]

RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

RewriteCond %{HTTP_HOST} ^girovagandoinmontagna\.com$ [OR]
RewriteCond %{HTTP_HOST} ^www\.girovagandoinmontagna\.com$
RewriteRule ^/?$ "http://girovagandoinmontagna\.com\/gim" [R=301,L]

# RewriteCond %{HTTP_HOST} ^www\.girovagandoinmontagna.com$ [NC]
# RewriteRule ^(.*)$ http://girovagandoinmontagna.com/$1 [R=301,L]

Ma poi mi è sorto un dubbio: anche nella cartella del forum esiste un file htacess, con questo, di qualedevo tenere conto? (scusate l'ignoranza). Di quello in radice o di quello in cartella del forum?

Codice: [Seleziona]
# PRETTYURLS MOD BEGINS
# Pretty URLs mod
# http://code.google.com/p/prettyurls/
# .htaccess file generated automatically on: May 5, 2015, 0:16

RewriteEngine on
RewriteBase /gim

RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1/gim/$1 [R=301,L]

# Questa serve ad evitare che la chat muoia
RewriteRule ^(chat)($|/) - [L]

# Rules for: actions
RewriteRule ^(activate|admin|ads|announce|attachapprove|badbehavior|buddy|calendar)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(clock|collapse|coppa|credits|deletemsg|display|dlattach|editpoll)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(editpoll2|emailuser|findmember|forum|portal|groups|help|helpadmin)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(im|jseditor|jsmodify|jsoption|lock|lockvoting|login|login2)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(logout|markasread|mergetopics|mlist|moderate|modifycat|modifykarma|movetopic)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(movetopic2|notify|notifyboard|openidreturn|pm|post|post2|printpage)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(profile|quotefast|quickmod|quickmod2|recent|register|register2|reminder)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(removepoll|removetopic2|reporttm|requestmembers|restoretopic|search|search2|sendtopic)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(smstats|suggest|spellcheck|splittopics|stats|sticky|theme|trackip)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(about:mozilla|about:unknown|unread|unreadreplies|verificationcode|viewprofile|vote|viewquery)/?$ ./index.php?pretty;action=$1 [L,QSA]
RewriteRule ^(viewsmfile|who|\.xml|xmlhttp|chat)/?$ ./index.php?pretty;action=$1 [L,QSA]

# Rules for: boards
RewriteRule ^([-_!~*'()$a-zA-Z0-9]+)/?$ ./index.php?pretty;board=$1.0 [L,QSA]
RewriteRule ^([-_!~*'()$a-zA-Z0-9]+)/([0-9]*)/?$ ./index.php?pretty;board=$1.$2 [L,QSA]

# Rules for: topics
RewriteRule ^([-_!~*'()$a-zA-Z0-9]+)/([-_!~*'()$a-zA-Z0-9]+)/?$ ./index.php?pretty;board=$1;topic=$2.0 [L,QSA]
RewriteRule ^([-_!~*'()$a-zA-Z0-9]+)/([-_!~*'()$a-zA-Z0-9]+)/([0-9]*|msg[0-9]*|new)/?$ ./index.php?pretty;board=$1;topic=$2.$3 [L,QSA]

# PRETTYURLS MOD ENDS
Titolo: Re:Forum raso al suolo
Inserito da: emanuele - Martedì, 12 Maggio 2015 10:46
Il mio post sopra, seppur criptico, era da intendersi "il redirect è già un 301, come dettato dal buon senso quando fai un redirect permanente di una risorsa". E non perché "OMG SEO!!!", ma perché è giusto che un redirect permanente di una risorsa sia così indicato.
SimplePortal 2.3.7 © 2008-2018, SimplePortal