Italian SMF

Supporto SMF => SMF 2.0 => Topic aperto da: mario71 - Martedì, 18 Agosto 2015 10:12

Titolo: installazione Simple Machines Forum problema creazione Database
Inserito da: mario71 - Martedì, 18 Agosto 2015 10:12
Buongiorno sto cercando di migrare il mio Forum SNITZ a SMF  l'unico problema che  arrivato ad un certo punto dell'installazione di SMF mi chiedono di creare sul Mysql un database chiamato SMF  con tabelle SMF_ l'unico problema che io non ci capisco nulla! Clicco su nuovo database e poi non so proprio che fare!!!!
Come settare insomma buio totale!
Datemi per favore una mano
Oppure qualche guida video o qualche file gia pronto da caricare sul database MYSQL che crei queste tabelle.

Grazie a tutti :D :D :D :D
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: Flavio93Zena - Martedì, 18 Agosto 2015 10:49
Ciao! In realtà dovrebbe bastare la creazione manuale (da pannello di controllo del server) del database, poi dovrebbe pensarci l'installer di SMF a fare tutta quella roba in automatico :)
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: mario71 - Martedì, 18 Agosto 2015 10:54
Grazie della risposta, ma la creazione manuale non so come si fa, ci sono un sacco di parametri da compilare.
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: Flavio93Zena - Martedì, 18 Agosto 2015 10:55
Io intendo prima di avviare l'installer, fai semplicemente "crea nuovo database" e basta, il resto lo farà SMF (che lo popolerà e configurerà a suo piacimento).
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: emanuele - Martedì, 18 Agosto 2015 14:40
Anche il database viene creato durante l'installazione, basta specificare l'utente e la password di mysql.
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: Flavio93Zena - Martedì, 18 Agosto 2015 14:59
Ooh già è vero, stavo pensando in ottica importazione :-[
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: mario71 - Martedì, 18 Agosto 2015 17:02
ho provato ma da questo errore.
Non so come fare , ci sta una soluzione?
Dovrei creare database SMF con prefisso SMF_ solo che come detto prima non so come si fa.
Cliccando su crea tabella esce un pannello e non so cosa fare.
il pannello lo ho allegato al primo messaggio.
Praticamente dovrei fare questo:
Creare un database
Ora, prima di poter installare SMF , avrete bisogno di un database per memorizzare tutte le informazioni del tuo forum , e un utente del database . Il database è quello che archivia tutti i tuoi soci , i post , le impostazioni e tutto quel genere di cose . L' utente del database è il modo SMF accedere al database per arrivare a tutte queste informazioni. Dal pannello di controllo host, utilizzare il sistema di gestione di database per creare un database . Se l'host non crea automaticamente un utente del database , crearne uno ora che dispone di autorizzazioni di SELECT, INSERT , UPDATE , DELETE , CREATE , ALTER , DROP , e INDEX . Prendere nota del database di URL , il nome del database , utente (login) nome e la password , in modo da poter dire di SMF tutto più tardi. Se avete problemi a fare questo , contattare il proprio host per aiuto .


Qualcuno potrebbe darmi un database pulito con solo nome utente in modo che lo carico sul mio e risolvo.

Non so come fare
Grazie
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: magicolotto - Martedì, 18 Agosto 2015 20:05
se hai fatto prove precedenti prova a controllare che non ci siano le vecchie tabelle in caso li cancelli e rifai
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: mario71 - Martedì, 18 Agosto 2015 21:40
No il DB è vuoto non ci sta nessuna tabella.
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: emanuele - Martedì, 18 Agosto 2015 21:41
Leggiamo i messaggi d'errore invece di provare a sparare senza sapere cosa stiamo facendo.

L'errore dice che SMF non può accedere al database.
Dai che hai inseriti deduco che sei su aruba.
Non hai bisogno di creare nessunissimo database, devi solo mettere i parametri giusti. Probabilmente hai scritto o il nome del database, o la password o l'indirizzo dell'host sbagliati.
Controlla che siano corretti e poi riprova.
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: mario71 - Martedì, 18 Agosto 2015 22:07
Devono essere per forza corretti ho controllato mille volte e poi l'errore dice che è riuscito ad entrare nel database.

!!Errore critico!
Il programma di installazione è stato in grado di accedere al "Sql350995_2 database". Con alcuni host, è necessario creare il database nel tuo pannello di amministrazione prima di SMF può usarlo. Alcuni aggiungono anche i prefissi - come il nome utente - ai vostri nomi di database.

Non so che fare

sono su Aruba
Grazie dell'aiuto...
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: magicolotto - Martedì, 18 Agosto 2015 22:49
cambia database Type
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: emanuele - Mercoledì, 19 Agosto 2015 08:39
Devono essere per forza corretti ho controllato mille volte e poi l'errore dice che è riuscito ad entrare nel database.
Io non so da dove venga quella traduzione, a giudicare dagli errori direi google translate, ma è palesemente sbagliata.
Prendi il messaggio in inglese, c'è "unable". Unable significa "incapace", quindi SMF è stato *incapace* di accedere al database.
Non è per diffidenza che lo dico, ma perché so abbastanza bene come SMF funziona, e quell'errore significa che SMF non può fare login al server MySQL, se non può fare login puoi creare tutte le tabelle che vuoi, ma SMF non si connetterà mai e non procederà con l'installazione ed anche una volta installato non ti mostrerà niente. Quindi, pausa e vediamo di risolvere le cose come devono essere risolte. ;)

Perché SMF non può connettersi?
L'unico motivo plausibile è che uno o più dei parametri di connessione (nome utente mysql, password, host, nome del database) è sbagliato.
L'alternativa è che ci sia qualche problema "lato aruba", non è da escludere, ma non mi è dato sapere.

Vogliamo fare la prova del nove?
Scarica http://www.mysqldumper.net/ e vedi se riesce a connettersi.
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: mario71 - Mercoledì, 19 Agosto 2015 09:27
Da non credere!!!!
i dati da me inseriti erano corretti allora....
Il problema sapete quale era?
Ho chiamato il servizio assistenza di Aruba e mi ha risolto il problema,  i dati erano corretti è bastato cancellare i files temporanei di Google Crome con CRTL +H  , poi ho fatto l'installazione aprendo una scheda in incognito e tutto è andato a buon fine.
MA COSE DA PAZZI e chi poteva pensare che il problema era quello!
Grazie a tutti e spero che la mia esperienza serva per far perdere meno tempo ad altri!!!!
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: emanuele - Mercoledì, 19 Agosto 2015 14:13
Ok,questo era un po' difficile da indovinare.
Effettivamente, ho notato che chrome ha una cache abbastanza aggressiva ed a volte non dimentica i file, però, in teoria, i file di SMF dovrebbero mandare l'header che il file è scaduto... :-\

Va beh, meglio così.
Titolo: Re: installazione Simple Machines Forum problema creazione Database
Inserito da: Flavio93Zena - Mercoledì, 19 Agosto 2015 16:31
Effettivamente, ho notato che chrome ha una cache abbastanza aggressiva ed a volte non dimentica i file, però, in teoria, i file di SMF dovrebbero mandare l'header che il file è scaduto... :-\
Vero, difatti uso questo ;D https://chrome.google.com/webstore/detail/cache-killer/jpfbieopdmepaolggioebjmedmclkbap
SimplePortal 2.3.7 © 2008-2018, SimplePortal