Autore Topic: Fotografie, posizione all'interno del topic,gestione anteprime e profilo colore.  (Letto 4505 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Agostino Noviello

  • Utente IS Lv.2
  • **
  • Post: 84
  • Sesso: Maschio
  • Eodem Mutato Resurgo
    • Mostra profilo
    • FotoFriends
  • Versione SMF: 2.0.x
Ciao a tutti, sto cercando di creare su l'ennesimo forum fotografico (fotofriends.it)

Piattaforma SMF2.0.8 , concatenata a Joomla (per la parte front-end), dbSQLi, provider Aruba (hosting linux)

Avrei bisogno di far postare le immagini nel topic con una dimensione ridotta e creare una finestra popup con le dimensioni effettive e le classiche freccettine destra e sinistra per far visualizzare le foto inserite nel topic.

Come fa facebook per intendersi...

Ma le mie esigenze non finiscono qua.
Mi occorrono almeno altre due cose:
1) Essenziale che la visualizzazione dell'immagine mantenga il proprio profilo colore.
2) Che l'immagine venga inserita dove si vuole (anche a metà del testo e non in coda al messaggio(come con questa immagine da me postata)

Qualcuno di voi sa indirizzarmi?
IO ho eseguito una ricerca a giro e sembra che ci sia solo APIMAGE che ottempera in parte a queste mie richieste.

Un  grazie a tutti per l'aiuto ^__^

Offline Filippo

  • Traduttore IS
  • *******
  • Post: 1100
  • Sesso: Maschio
    • Mostra profilo
    • Gilera bi4
  • Versione SMF: 2.0.x
Per inserire le immagini dentro il testo  e non solo in coda io ho usato questa

https://github.com/Spuds/SMF-ILA

Spulciando ho trovato questa che ti visualizza le immagini tutte le immagini del post  (penso)

http://custom.simplemachines.org/mods/index.php?mod=3388

Non so se sono compatibili tra loro....

Offline Agostino Noviello

  • Utente IS Lv.2
  • **
  • Post: 84
  • Sesso: Maschio
  • Eodem Mutato Resurgo
    • Mostra profilo
    • FotoFriends
  • Versione SMF: 2.0.x
Per inserire le immagini dentro il testo  e non solo in coda io ho usato questa

https://github.com/Spuds/SMF-ILA...
Grazie per l'info, la sto testando ^__^

La mod con la versione 2.08 funziona solo se:
1) Scomponiamo il pacchetto zip
2) Rinominiamo il file instal-2.xml in install.xml
3) Modifichiamo all'interno del file "package-info.xml" il riferimento al file sopradescritto (togliamo il "-2")
4) Ricompattiamo e lo carichiamo da pannello e/o da ftp

Questa mod però crea un duplicato, ovvero si vede fra il testo ed in fondo al topic.
Qualora si tolga la "visualizzazione dell'immagine in fondo al topic", si toglie anche la visualizzazione dell'immagine all'interno del testo :(

Manca (per ora non l'ho trovato) un modo per impostare il valore IN LINE desirato come "predefinito" e nascondere il pannello all'utente.

Per APIMAGE, non mi vuol funzionare, ma questa è un'altra storia ;)
« Ultima modifica: Martedì, 01 Luglio 2014 07:45 da xtarabash »

Offline Filippo

  • Traduttore IS
  • *******
  • Post: 1100
  • Sesso: Maschio
    • Mostra profilo
    • Gilera bi4
  • Versione SMF: 2.0.x
A me la "ILA" funziona senza creare duplicati.

Forrse era da installare in modalità compatibilità? non ricordo.

L'altra non la conosco (appena installata in un forum di prova, ma non vedo differenzre, come se non funzionasse)
« Ultima modifica: Martedì, 01 Luglio 2014 08:57 da Filippo »

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
La mod con la versione 2.08 funziona solo se:
1) Scomponiamo il pacchetto zip
2) Rinominiamo il file instal-2.xml in install.xml
3) Modifichiamo all'interno del file "package-info.xml" il riferimento al file sopradescritto (togliamo il "-2")
4) Ricompattiamo e lo carichiamo da pannello e/o da ftp
O_o

Questa mi giunge nuova, e soprattutto non vedo la "necessità" di un cambio simile, che conduce esattamente allo stesso risultato (e tra l'altro il file si chiama install-2.0.xml, non install-2.xml).

Detto questo, sei sicuro di non aver ricevuto errori mentre la installatvi?
Stai per caso usando un tema diverso da quello di default?
Magari le modifiche al tema non sono state apportate?

Offline Agostino Noviello

  • Utente IS Lv.2
  • **
  • Post: 84
  • Sesso: Maschio
  • Eodem Mutato Resurgo
    • Mostra profilo
    • FotoFriends
  • Versione SMF: 2.0.x
...e tra l'altro il file si chiama install-2.0.xml...
Yes chiedo venia :(

Citazione
Detto questo, sei sicuro di non aver ricevuto errori mentre la installatvi?
Stai per caso usando un tema diverso da quello di default?
Magari le modifiche al tema non sono state apportate?
Niente di tutto ciò, uso il tema di default "Curve" che tra l'altro trovo molto piacevole e lo dovrò trasportare anche su joomla.
Ma torniamo a noi, se non modifico il nome del file e relativo collegamento, all'interno della board non compare nella lista delle mod da installare ... non chiedermi il perchè  ???

Però se faccio tutta sta trafila, la mod si vede e si installa correttamente :)

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Ma torniamo a noi, se non modifico il nome del file e relativo collegamento, all'interno della board non compare nella lista delle mod da installare ... non chiedermi il perchè  ???

Però se faccio tutta sta trafila, la mod si vede e si installa correttamente :)
Probabilmente allora ti basta ricomprimere il pacchetto senza modificare niente.

Controlla che le modifiche a Display.template.php siano state eseguite:
https://github.com/Spuds/SMF-ILA/blob/master/install-2.0.xml#L139

Offline Agostino Noviello

  • Utente IS Lv.2
  • **
  • Post: 84
  • Sesso: Maschio
  • Eodem Mutato Resurgo
    • Mostra profilo
    • FotoFriends
  • Versione SMF: 2.0.x
mmm sembrerebbe di no :o

Per chiarezza, parliamo del file "percorso.../Themes/default/display.template.php"
Ed al suo interno dovrei vedere il codice di ILA
Giusto?

Non leggo nulla, almeno sembra. Ti allego tale file

Ma perchè allora quando faccio le prove mi viene la tendina di utilizzo di ILA accanto a sfoglia?

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Fotografie, posizione all'interno del topic,gestione anteprime e profilo colore.
« Risposta #8 il: Mercoledì, 02 Luglio 2014 10:33 »
L'allegato che hai messo l'hai modificato?
Perché io il codice di ILA ce lo vedo...

Offline Agostino Noviello

  • Utente IS Lv.2
  • **
  • Post: 84
  • Sesso: Maschio
  • Eodem Mutato Resurgo
    • Mostra profilo
    • FotoFriends
  • Versione SMF: 2.0.x
Perfetto son pure cecato!!!  :)
No no, niente modifiche.
Quindi non so perchè ma a me il file install_2.0.xml non lo fa vedere.

Controllando la composizione degli altri package, ho notato che tutti hanno all'interno un file chiamato INSTALL.XML  e molti di essi oltre a questo file hanno il file instal_xxxx.xml
Ho controllato che sempre i due file corrispondono.
Moltro probabilmente è un modus operandi per marcare le versioni di scrittura ???
Se così fosse, è molto probabile che ci sia stata una dimenticanza da parte del creatore in fase di creazione nel pacchetto che ho scaricato IO.
Vabbè, ripeto, a parte questa pecca il tutto funziona.

OT/
Purtroppo più vado avanti nell'approfondire la conoscenza di SMF e più mi accorg che questa piattaforma ha poco destrezza nella gestione di file grafici :(
/OT

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Fotografie, posizione all'interno del topic,gestione anteprime e profilo colore.
« Risposta #10 il: Venerdì, 04 Luglio 2014 16:07 »
arg... credo di aver iniziato la risposta, ma non premuto post ieri... lol

OT/
Purtroppo più vado avanti nell'approfondire la conoscenza di SMF e più mi accorg che questa piattaforma ha poco destrezza nella gestione di file grafici :(
/OT
Beh, SMF non nasce come una gallery fotografica, ma come forum con allegati. Per loro natura gli allegati sono un po' limitati.

Vabbè, ripeto, a parte questa pecca il tutto funziona.
Beh, ma se l'immagine si vede doppia... no, non funziona... :)
Stavo quasi per suggerirti di nascondere l'area dove normalmente vengono messi gli allegati, ma se poi qualcuno non usa il tag "in-line", l'allegato non si vede... :-\

Offline radu81

  • Staff IS
  • *******
  • Post: 363
  • Sesso: Maschio
    • Mostra profilo
  • Versione SMF: -
  • Versione ElkArte: 1.1.x
Re:Fotografie, posizione all'interno del topic,gestione anteprime e profilo colore.
« Risposta #11 il: Venerdì, 04 Luglio 2014 21:58 »
a me quella mod funziona correttamente, l'unica cosa di github è che ti crea un file zip con tutto il contenuto all'interno di una cartella. Basta szippare e ricreare il file zip per installare la mod.

Oltre a ILA uso anche HS4SMF sempre di Spuds https://github.com/Spuds/SMF-HS4SMF

Offline Agostino Noviello

  • Utente IS Lv.2
  • **
  • Post: 84
  • Sesso: Maschio
  • Eodem Mutato Resurgo
    • Mostra profilo
    • FotoFriends
  • Versione SMF: 2.0.x
a me quella mod funziona correttamente...

OK da quanto dice Ema e te incomincio ad avere davvero dubbi sul funzionamento.
Mi puoi perfavore mettere o mandare in MP uno screenshot di un messaggio in fase di scrittura e del relativo topic inviato per capire come deve uscire l'nterfaccia.


@EMA
Quindi se ho capito bene, (a conf funzionante) se uso la mod ILA posso tranquillamente nascondere l'allegato in coda?

Offline Filippo

  • Traduttore IS
  • *******
  • Post: 1100
  • Sesso: Maschio
    • Mostra profilo
    • Gilera bi4
  • Versione SMF: 2.0.x
così?
« Ultima modifica: Lunedì, 07 Luglio 2014 14:55 da Filippo »

Offline Agostino Noviello

  • Utente IS Lv.2
  • **
  • Post: 84
  • Sesso: Maschio
  • Eodem Mutato Resurgo
    • Mostra profilo
    • FotoFriends
  • Versione SMF: 2.0.x
Grazie ^__^
Ci sono le stesse opzioni che appaiono a me  ???

A questo punto se non è chiedere troppo, mi puoi postare il topic "inviato" selezionando l'opzione "miniatura in linea col testo" (per intendersi volevo sapere se in fondo al topic ti si ripete l'immagine o l'elenco testuale dell'allegato).

Grazie ancora

 

Eseguire file PHP all'interno di un TOPIC

Aperto da i_fiorentinoSezione Mods - Modifiche SMF

Risposte: 4
Visite: 1386
Ultimo post Giovedì, 19 Settembre 2013 21:27
da i_fiorentino
tabella profilo utente nei topic

Aperto da TiMESezione SMF 2.0

Risposte: 6
Visite: 1137
Ultimo post Domenica, 10 Agosto 2014 17:01
da emanuele
Spostare posizione pulsanti all'interno del menù

Aperto da Agostino NovielloSezione SMF 2.0

Risposte: 3
Visite: 1046
Ultimo post Martedì, 30 Settembre 2014 21:00
da Agostino Noviello