Autore Topic: Problema aggiornamento da 2.0.6 a 2.0.7  (Letto 3557 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Problema aggiornamento da 2.0.6 a 2.0.7
« il: Mercoledì, 03 Dicembre 2014 10:25 »
...ho aperto un topic sul supporto di SMF e poi mi sono accorto che per qualche motivo che non conosco, sarà ben difficile per me ricevere lì una risposta al mio problema e quindi mi accingo a ripetere qui la cosa aprendo un nuovo topic e copiando pari pari quello che ho scritto di là:

"ciao e scusate innanzitutto il disturbo!
cerco spesso di risolvere da solo le problematiche che mi si presentano leggendo i commenti nei vari topic che trattano man mano le argomentazioni che mi interessano e devo dire che fra alti e bassi, problemi piccoli e problemi grandi, sono ormai ben sette anni che gestisco un forum che inizialmente camminò per diversi anni con la 1.1.ecc e che da un annetto fila liscio avendo aggiornato il tutto al 2.0.ecc
sono riuscito bene o male a fare funzionare buona parte di tutte le mod che ho sempre utilizzato avendo ben capito (grazie al supporto di emanuele e darknico che si sbattono da anni per aiutare noi tutti) dove andare ad operare manualmente di volta in volta.
Adesso ho un problema dal quale non riesco a venirne a capo, ovvero l'aggiornamento da 2.0.6 a 2.0.7 (e ovviamente sono rimasto parecchio indietro essendo nel frattempo usciti altri aggiornamenti...)
in qualsiasi modo opero, dopo che il pacchetto 2.0.7 Update rileva in fase di installazione tre errori sul Themes.template ed uno sul Subs-Editor, a files modificati manualmente nel pannello admin il pacchetto risulta perfettamente installato ma mi sparisce l'index....
ovvero, il browser (sia esso Chrome, Firefox, Opera o IE) mi rimanda ad una pagina assolutamente bianca
Comincio seriamente a preoccuparmi di non riuscire a stare al passo con i futuri aggiornamenti...
avete qualche consiglio?
tranquilli che aspetto"

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #1 il: Mercoledì, 03 Dicembre 2014 11:55 »
Prova ad allegare i due file. ;)

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #2 il: Giovedì, 04 Dicembre 2014 13:20 »
intanto, grazie per la pronta risposta, ema...
ti allego i due files così come sono ora su server, senza le modifiche che mi procurano il "problema" di cui sopra; modifiche che nelle prove ho ovviamente fatto così come indicatomi dal gestore di installazioni del pannello admin, lì dove rileva il fatidico "test fallito" in rosso
spero tu riesca dove io ho fallito, sigh

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #3 il: Venerdì, 05 Dicembre 2014 01:13 »
Bump altrimenti perdo il topic, domani...

Offline Flavio93Zena

  • Staff IS
  • *******
  • Post: 3056
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #4 il: Venerdì, 05 Dicembre 2014 03:22 »
Esiste un pulsante fantastico chiamato "marca come non letto" ;D :P

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #5 il: Venerdì, 05 Dicembre 2014 13:40 »
In Subs-Editor.php hai aggiunto un " vertically-align: middle" alla stringa che andrebbe sostituita (tra l'altro la sintassi è sbagliata, perché non è "vertically", ma è "vertical").
Non saprei dirti il perché l'hai fatto, ma come suggerimento, la prossima volta usa i css, ad esempio aggiungendo alla fine di index.css:
Codice: [Seleziona]
.smiley>img {
    vertical-align: middle !important;
}
Sovrascrivi quello che hai con il file allegato.

Per quanto riguarda Themes.template.php è già stato aggiornato in precedenza a 2.0.7, quindi puoi semplicemente ignorare l'errore. Questo però evidenzia che hai già fatto e tolto l'installazione almeno una volta.


Yup, lo so Flavio, ma siccome uso spesso la home con gli ultimi 10 messaggi, se uno non letto scappa fuori dalla lista non lo vedo più. ;)

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #6 il: Sabato, 06 Dicembre 2014 01:08 »
sovrascritto ma l'index rimane inesorabilmente bianco quando vado ad applicare il pacchetto di update, ritornando magicamente al suo fulgore contenutivo appena vado a disinstallarlo (non trovando neanche più errori da segnalarmi*... bah)
* riprovato ad installare e non trova più errori ma... index white! grrr

mmm... presumo ci sia altro che da fastidio

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #7 il: Sabato, 06 Dicembre 2014 11:11 »
E come fai a disinstallarlo?

Offline Flavio93Zena

  • Staff IS
  • *******
  • Post: 3056
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #8 il: Sabato, 06 Dicembre 2014 14:59 »
Già... La cosa mi incuriosisce. Come fai a dire che se lo installi e ti fa venire schermata bianca poi però hai la possibilità di disinstallarlo? E' un controsenso :| non credo tu vada a ri-modificarti i file a mano, visti anche i piccoli cambiamenti per aggiornare le versioni sarebbe una faticaccia immane e inutile...

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 381
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #9 il: Sabato, 06 Dicembre 2014 17:14 »
non credo tu vada a ri-modificarti i file a mano, visti anche i piccoli cambiamenti per aggiornare le versioni sarebbe una faticaccia immane e inutile...

Backup ?? :))

Offline Flavio93Zena

  • Staff IS
  • *******
  • Post: 3056
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #10 il: Sabato, 06 Dicembre 2014 17:25 »
Non è che sei uno di quelli (come me) che ha mille mod installate? Potresti postarne l'elenco che almeno riusciamo a capire cos'hai su quel forum? :P

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #11 il: Domenica, 07 Dicembre 2014 00:20 »
    è vero... in sette anni di vita di forum, di mod installate c'è n'è davvero parecchie...
    per l'esattezza 60 e con tutte e 60 ho passato l'upgrade a 2.0.6 da 1.1.19

E come fai a disinstallarlo?

è l'index che diventa pagina bianca, non il pannello admin, quindi riesco a disinstallarlo nella gestione pacchetti

ah si... elenco mod:

1.   AdsToppost    1.0
2.   Socialize    1.8
3.   Simple Image Upload
4.   Default Avatar    2.3
5.   Ohara YouTube Embed
6.   Cumulus Congestus    1.0
7.   BackGround Tag    1.0 
8.   Board Notes    1.0.8
9.   Mobile Device Detect    0.2.2
10.   Breeze    1.0
11.   Allocate More RAM mod    1.0
12.   E-Arcade    Beta4-SMF2rc1
13.   Footer Menu    1.1.2
14.   Similar Topics    0.6
15.   Copy Topics    1.6
16.   YandexGarland    1.2
17.   SMF 1.1.19 / 2.0.6 Update
18.   Simple .htaccess Proxy Blocker Mod    1.1
19.   Simple .htaccess Cache Mod    2.6
20.   KeyCAPTCHA for SMF    2.6
21.   Users mass actions    0.1.1
22.   Tidy Child Boards    1.4
23.   Thank-o-matic    3.0
24.   Users Online Today    2.0.3
25.   SMF 2.0.5 Update    1.0
26.   Move recent to the top    2.7
27.   Medal Honor For Years    1.0
28.   Live Clock In Header    1.2
29.   Sortable Packages (and Installed Time)    1.3.4
30.   Enhanced Dropdown    1.3
31.   Hide Tag Special    3.0
32.   Avatar Rounded Corners    1.0
33.   Align text with Smiley    1.3
34.   nCode Image Resizer    1.4
35.   Characters remaining of post    1.0
36.   Boilerplates for posts    3.0
37.   Spoiler Tag    0.7.2a
38.   Topics list support [Taby]    1.05
39.   Adk Rules Posts    1.0
40.   Adk topic button    1.0
41.   Adk Display Moderators    1.0
42.   ed2k links support Taby    2.7
43.   Add Table, Td, Tr Button    1.0
44.   Add list li Button    1.0
45.   Activity in Profile    1.1
46.   magnet links support    0.2
47.   Custom Copyright    1.2
48.   Previous and Next Topic Enhancement    1.0
49.   Hack's Park Shoutbox    2.0.2
50.   Favicon    1.2
51.   Project Snow 1.2    1.2
52.   SMF Staff Page    1.7
53.   The Rules    1.3
54.   Default Avatar    1.1.1
55.   Add IP2Location to Track IP    1.3
56.   Reason For Editing Mod    2.3.2
57.   Display Signatures Only Once Per Page    1.0.3
58.   Skype Name Mod    1.0
59.   Alternate Text for Member Group Images    0.3.1
60.   Group Moderators    1.5[/list]
« Ultima modifica: Domenica, 07 Dicembre 2014 00:22 da Raffomix »

Offline Flavio93Zena

  • Staff IS
  • *******
  • Post: 3056
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #12 il: Domenica, 07 Dicembre 2014 00:42 »
Tsk tsk, ne ho più del doppio io :P

Dunque un'altra domanda sorge spontanea. Come diamine fai ad arrivare al pannello admin (e da qualunque altra parte) se l'indice non va? Tramite link diretti?

Altra cosa... hmm.. Forse qualcosa che abbia alterato il boardindex.template.php? Qui aspetterei emanuele, oltretutto è tardissimo (stanco) e diverse mod (nonostante ne abbia di più) non le ho io stesso :P Tuttavia in ogni caso le pagine bianche devono essere loggate in un elenco sul tuo host... Di solito è error.log o un nome del genere...
« Ultima modifica: Domenica, 07 Dicembre 2014 00:43 da Flavio93Zena »

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #13 il: Domenica, 07 Dicembre 2014 11:06 »
E come fai a disinstallarlo?

è l'index che diventa pagina bianca, non il pannello admin, quindi riesco a disinstallarlo nella gestione pacchetti
Ohh, questo è *molto* importante.

Allora, ci sono due possibilità:
1) applichi la patch, scarichi tutti i file (php) di Sources e Themes li impacchetti e me li passi,
2) iniziamo col quarto grado, tanto per iniziare:
* accedi come visitatore vedi qualcosa o bianco?
* se guardi una sezione si vede o è bianca?
* se guardi un topic si vede o no?
Poi ne verranno altre. ;)

Offline Flavio93Zena

  • Staff IS
  • *******
  • Post: 3056
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #14 il: Domenica, 07 Dicembre 2014 13:20 »
* Flavio93Zena chide gentilmente ad emanuele se potesse scrivere anche il motivo per cui fa certe domande così che possa capire pure lui cosa gli passa per la testa :P

EDIT: orrore ortografico...
« Ultima modifica: Lunedì, 08 Dicembre 2014 02:08 da Flavio93Zena »

 

Problema aggiornamento 2.0.14

Aperto da titaniumSezione SMF 2.0

Risposte: 29
Visite: 3062
Ultimo post Mercoledì, 03 Gennaio 2018 05:40
da Flavio93Zena
Problema login dopo aggiornamento 2.0.14

Aperto da stefano55Sezione SMF 2.0

Risposte: 2
Visite: 756
Ultimo post Domenica, 28 Maggio 2017 22:10
da stefano55
Problema Faccine dopo aggiornamento

Aperto da bollicine1987Sezione SMF 2.0

Risposte: 2
Visite: 588
Ultimo post Martedì, 30 Maggio 2017 19:11
da bollicine1987