Autore Topic: Problema aggiornamento da 2.0.6 a 2.0.7  (Letto 3560 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #15 il: Domenica, 07 Dicembre 2014 13:59 »
Beh, ogni pagina carica un set di file specifici, più un set generico.
Ovviamente, avendo accesso al pannello di admin significa che index.php o Load.php o Subs.php funzionano correttamente, altrimenti non vedrebbe proprio niente.
Ora, essendo board idnex quello che muore, già il campo è molto ristretto, ma nella patch 2.0.6 = > 2.0.7, di primo acchito, non vedo niente che potrebbe impedire il caricamento di BoardIndex, ma lasciar funzionare il pannello di admin, ce ne potrebbero essere un paio, ma è una possibilità abbastanza remota.
L'aver installato parecchi mod non aiuta, perché ognuno potrebbe usare uno dei file a cui io non sto pensando, quindi... sparo qualche domanda.

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #16 il: Lunedì, 08 Dicembre 2014 01:13 »
mettiamola così: io sono nel pannello admin, vado nel gestore pacchetti ed installo (ormai è già caricata e presente su server) la patch denominata "SMF 2.0.7 Update" all'atto dell'installazione, lì dove prima mi dava degli errori nei due files che andavo a menzionare (e che ho allegato qui in una precedente risposta) ora non mi dà errori, clicco giù in basso a destra sul bottone "installa adesso" e tutto pare andare a buon fine quindi, su in alto nella pagina faccio tasto destro sulla scritta Indice scegliendo "apri link in un altra scheda" e arrivo nella fatidica pagina bianca....
altra prova (sempre rimanendo nel pannello admin, perchè a questo punto ho paura di uscirne visto che anche aggiornando la pagina questo non scompare e quindi mi rimane unico punto di riferimento operativo) vado sulla gestione sezioni e cliccando su una qualsiasi sezione (senza modificare, solo cliccando sul nome della stessa di destro e sempre facendo "apri link in un altra scheda") la sezione mi si apre, cllicco su topic a caso e questi si aprono cerco di andare sull'indice da qui e... è bianco! quindi presumo che il problema è sull'index! spero di aver fatto capire bene le cose...
ora non posso, domani in giornata reinstallo la patch e allego i due files modificati, ciao... e buona notte

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #17 il: Lunedì, 08 Dicembre 2014 13:58 »
Applica la patch e poi mandami i file modificati dalla patch, la lista la puoi vedere qui:
http://custom.simplemachines.org/upgrades/index.php?action=upgrade;file=smf_patch_2.0.7.tar.gz;smf_version=2.0.6
questo è veramente strano... :-\

Che versione di php hai?

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #18 il: Martedì, 09 Dicembre 2014 13:16 »
non ci credo!
ho rifatto tutto come sempre ed adesso... è tutto a posto!
vedo l'index e nel pannello admin risulta il forum aggiornato a 2.0.7
adesso mi faccio un giro per controllare che sia tutto a posto.
grazie per l'apporto e spero di non trovare problemi con gli altri due aggiornamenti che mi toccherà fare a breve

siete grandi, sul serio!

Offline Filippo

  • Traduttore IS
  • *******
  • Post: 1100
  • Sesso: Maschio
    • Mostra profilo
    • Gilera bi4
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #19 il: Martedì, 09 Dicembre 2014 13:19 »
ed ora devi arrivare alla 2.0.9

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4968
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #20 il: Martedì, 09 Dicembre 2014 13:28 »
Effettivamente... dato che la 2.0.7 se non erro ha qualche problemuccio di "peso" (che a dire il vero non è stato completamente risolto con la 2.0.8 dato che ho dovuto ri-applicare del codice preso altrove per poter far funzionare a dovere un forum a cui fornisco aiuto) e che l'unica vera release con fix di sicurezza è appunto la 2.0.9.

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #21 il: Martedì, 09 Dicembre 2014 13:30 »
spettacolo!

risolto con 2.07 e tutto è filato liscio fino al 2.09
ancora grazie.... :)

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #22 il: Martedì, 09 Dicembre 2014 17:45 »
ecco saltato fuori un problema:
uso la mod Topics list support [Taby] della quale avevo già modificato in passato il file install forzando la mano sulla versione, così come mi insegnaste tempo addietro.
all'apertura delle liste automatiche mi appare questo:

Citazione
Unknown column 'b.board_order' in 'order clause'
File: /home2/ed2k4buz/public_html/forum/Sources/Subs.php
Riga: 4870

Nota: Sembra che il tuo database debba essere aggiornato. I file del forum risultano attualmente alla versione SMF 2.0.9, mentre il database corrisponde alla versione 2.0.4. Il problema potrebbe essere risolto eseguendo l'ultima versione del file upgrade.php.

sto cercando di entrare via ftp con filezilla per andare a vedere questa riga 4870 del file subs.php ma non riesco ad entrare
sto cercando di entrare sul c-panel tramite web ma manco di lì riesco
credete ci siano problemi al server?
e poi... come si fa ad aggiornare il database? non viene aggiornato dagli update?

P.S. il forum cammina comunque bene

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #23 il: Martedì, 09 Dicembre 2014 17:52 »
ok...ok... sono andato nel registro errori, e lì trovando l'errore della non visualizzazione del topic mi rende il link del file facendomi arrivare alla riga 4870 (tramite popup)
e l'errore è:

Citazione
==>4870:          );

???????????

Offline Lucarella

  • Utente IS Lv.3
  • ***
  • Post: 381
    • Mostra profilo
    • eMuleItalia.eu
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #24 il: Martedì, 09 Dicembre 2014 17:54 »
Raffo, leggi qui la soluzione a questo problema http://www.italiansmf.net/forum/index.php?topic=992.msg4964#msg4964
Con il mod di Tabì all'uptade 2.0.8 il problema lo abbiamo avuto un pò tutti ;)

Per quanto riguarda l'accesso al FTP, è un problema di hosting non di SMF

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #25 il: Martedì, 09 Dicembre 2014 18:22 »
grazie, Lucarella!
appena riesco ad accedere tramite ftp faccio la modifica  ;D

Offline Raffomix

  • Utente IS
  • *
  • Post: 40
    • Mostra profilo
    • Brothers-revolution
  • Versione SMF: 2.0.x
Re:Problema aggiornamento da 2.0.6 a 2.0.7
« Risposta #26 il: Martedì, 09 Dicembre 2014 18:26 »
ok, sistemato...
grazie grazie grazie

 

Problema aggiornamento 2.0.14

Aperto da titaniumSezione SMF 2.0

Risposte: 29
Visite: 3063
Ultimo post Mercoledì, 03 Gennaio 2018 05:40
da Flavio93Zena
Problema login dopo aggiornamento 2.0.14

Aperto da stefano55Sezione SMF 2.0

Risposte: 2
Visite: 756
Ultimo post Domenica, 28 Maggio 2017 22:10
da stefano55
Problema Faccine dopo aggiornamento

Aperto da bollicine1987Sezione SMF 2.0

Risposte: 2
Visite: 588
Ultimo post Martedì, 30 Maggio 2017 19:11
da bollicine1987