Autore Topic: Impossibile accedere al percorso di caricamento degli allegati!  (Letto 3513 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 561
    • Mostra profilo
  • Versione SMF: 2.0.x
Impossibile accedere al percorso di caricamento degli allegati!
« il: Sabato, 07 Gennaio 2017 12:54 »
Dopo l'aggiornamento del forum è sparita la mia immagine avatar (e questo è il meno) ma sopratuttutto non funzionano più gli allegati, appare il messaggio

Citazione
Impossibile accedere al percorso di caricamento degli allegati!

Cosa posso fare?

Offline Flavio93Zena

  • Staff IS
  • *******
  • Post: 3051
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: 1.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #1 il: Sabato, 07 Gennaio 2017 14:52 »
Esiste la cartella allegati sul server?
Che permessi ha? In qualunque caso buttaci un 755 (*sulla cartella, non sui file singoli, che se non ricordo male sono 644*)

Stessa cosa per la cartella avatar.

Controlla anche che i percorsi delle due cartelle siano corretti in amministrazione (non ricordo in quale area si può vedere :/). Diversamente usa repair settings - http://wiki.simplemachines.org/smf/Repair_settings.php

Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 561
    • Mostra profilo
  • Versione SMF: 2.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #2 il: Sabato, 07 Gennaio 2017 17:42 »
ce ne sono parecchie...
applico 755 a tutte?
PS: ma gli avatar che caricano gli utenti dove vanno a finire?

Offline Flavio93Zena

  • Staff IS
  • *******
  • Post: 3051
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: 1.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #3 il: Sabato, 07 Gennaio 2017 18:12 »
Gli avatar sono trattati come allegati se non ricordo male, e ancora se non erro è per questo che l'azione per richiamarli contiene type=avatar :)
755 alle cartelle, non farti problemi (con Filezilla ci metti 30 secondi a dire tanto, perchè basta selezionare le cartelle e fa le sottocartelle in automatico).

Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 561
    • Mostra profilo
  • Versione SMF: 2.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #4 il: Sabato, 07 Gennaio 2017 18:19 »
ho reimpostato le cartelle col 755, ma appare il messaggio di errore: la cartella di destinazione degli allegati =0

Hp riprovato e appare

Citazione
L'allegato non può essere salvato. La causa è da ricercare nel tempo di caricamento troppo lungo o nella dimensione del file, superiore a quella ammessa dal server.

Consultare l'amministratore del server per ulteriori informazioni.

l'allegato è 129k.


Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4965
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #5 il: Sabato, 07 Gennaio 2017 19:24 »
I permessi sulla cartella allegati, da quel che ricordo, hanno poca influenza (a meno che non siano completamente sballati, del tipo 00, ma a quel punto non li sistemi da ftp).

Considerando che:
1) il problema sorge con l'ultima patch,
2) quest'ultimo aggiornamento non tocca niente che abbia direttamente a che fare con gli allegati,
3) che stai usando il mod per directory multiple,
il mio sospetto è che abbia a che fare con serialize/unserialize.
Allora, tagliamo la testa al toro, da phpmyadmin esporta la tabella smf_settings (tutorial che dovrebbero andare uno, due) e mandamela via mail, al solito emanuele45 al dominio gmail.com che controllo.

Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 561
    • Mostra profilo
  • Versione SMF: 2.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #6 il: Sabato, 07 Gennaio 2017 20:05 »
eseguo! Grazie. Ho scoperto che i vecchi allegati non si vedono... (che prima si vedevano) quindi direi che da qualche parte c'è un errore nella impostazione della directory. Ho provato a correggere da pannello di amministrazione ma esce un avviso che ha fermato il comando per non sovraccaricare il server, però la funziona si inchioda in loop
« Ultima modifica: Sabato, 07 Gennaio 2017 21:22 da wild56 »

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4965
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #7 il: Sabato, 07 Gennaio 2017 21:27 »
Il problema è "semplicemente" che le vecchie directory sono stata rimosse dalla configurazione.
Il perché mi è ignoto al momento (ho qualche sospetto, ma non ne son sicuro).

Hai per caso un backup del database "recente"?

Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 561
    • Mostra profilo
  • Versione SMF: 2.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #8 il: Sabato, 07 Gennaio 2017 22:00 »
oddio no... forse sul server nei backup automatici

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4965
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #9 il: Sabato, 07 Gennaio 2017 22:43 »
Scarica repair settings da http://download.simplemachines.org/?tools e prova ad usarlo.
Con un po' di fortuna dovrebbe ritrovare tutte le directory degli allegati e cercare di sistemarle.

Offline Flavio93Zena

  • Staff IS
  • *******
  • Post: 3051
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: 1.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #10 il: Domenica, 08 Gennaio 2017 03:05 »
L'avevo suggerito nella risposta 1, credevo ci avesse provato ;D

Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 561
    • Mostra profilo
  • Versione SMF: 2.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #11 il: Domenica, 08 Gennaio 2017 09:31 »
Allora, ho provato il repair, ora mi pare che funzioni il caricamento degli allegati, ma i vecchi allegati non si vedono (404 - Allegato non trovato), idem per gli avatar... :(
« Ultima modifica: Domenica, 08 Gennaio 2017 09:47 da wild56 »

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4965
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #12 il: Domenica, 08 Gennaio 2017 11:44 »
Questo l'ho scritto un po' al volo e testato in condizioni abbastanza ottimali, ma dovrebbe funzionare.

Carica l'allegato come se fosse un repair_settings, e raggiungilo dal browser.
Lui macinerà un po' e poi ti restituirà del testo.
Copia il testo, salvalo in un file e mandamelo via mail.
In teoria gli allegati dovrebbero tornare a funzionare, a meno che tu abbia raggiunto un limite tecnico, in tal caso vedremo cosa fare.

Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 561
    • Mostra profilo
  • Versione SMF: 2.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #13 il: Domenica, 08 Gennaio 2017 13:55 »
allegati e avatar non si vedono. Rispetto a prima si riescono a caricare, ma li vede solo chi li ha postati...

http://girovagandoinmontagna.com/gim/comunicazioni/problemi-con-gli-allegati/

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4965
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Impossibile accedere al percorso di caricamento degli allegati!
« Risposta #14 il: Domenica, 08 Gennaio 2017 15:30 »
O_o

Il mio script non fa altro che prendere gli allegati dal database, verificare dove si trovano e correggere il percorso di conseguenza, quindi non può non funzionare... :-\

Tagliamo la testa al toro, mi serve accesso ftp per vedere cosa succede.

 

Posizione degli Allegati

Aperto da magicolottoSezione Mods - Modifiche SMF

Risposte: 1
Visite: 574
Ultimo post Mercoledì, 11 Marzo 2015 11:41
da Darknico
Impossibile accedere

Aperto da Marco97Sezione SMF 2.0

Risposte: 25
Visite: 2798
Ultimo post Mercoledì, 29 Luglio 2015 18:09
da Marco97
sparite le anteprime degli allegati

Aperto da luca16568Sezione SMF 2.0

Risposte: 4
Visite: 749
Ultimo post Giovedì, 22 Marzo 2018 08:35
da radu81