Autore Topic: Tutte le mod "si sono disinstallate"  (Letto 95 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 559
    • Mostra profilo
  • Versione SMF: 2.0.x
Tutte le mod "si sono disinstallate"
« il: Domenica, 06 Ottobre 2019 22:18 »
Ciao tutti, di punto in bianco mi sono accorto che il simpleportal aveva smesso di funzionare... non c'era più. Sono andato nel pannello di controllo e ho visto che praticamente tutte le mod non sono installate...
Che diavolo può essere successo?

Ho provato a reinstallare simply portal e pare sia tornato a funzionare.... grazie a dio con la configurazione che aveva prima.
Cosa devo fare ora? Reinstallare tutte le mod? Ripristinare una versione precedente del forum? (dovrei avere il backup sul server)

Online Flavio93Zena

  • Staff IS
  • *******
  • Post: 3035
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: 1.0.x
Re:Tutte le mod "si sono disinstallate"
« Risposta #1 il: Domenica, 06 Ottobre 2019 22:38 »
https://download.simplemachines.org/index.php?thanks;filename=fix_packages.php

Caricalo sul server, vacci sopra con il browser (tuosito/fix_packages.php), usalo e (importante) CANCELLALO quando hai finito.

Ti consente di marcare come installate le mod che figurano come "disinstallate" ma in realtà non lo sono. Se invece sono davvero disinstallate... Semplicemente re-installale.
Comunque è logicamente impossibile che le mod si disinstallino da sole. Tale operazione modifica diversi file e il database in modo molto preciso, non lo può fare il server "a caso".

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4954
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Tutte le mod "si sono disinstallate"
« Risposta #2 il: Lunedì, 07 Ottobre 2019 19:03 »
Ciao tutti, di punto in bianco mi sono accorto che il simpleportal aveva smesso di funzionare... non c'era più. Sono andato nel pannello di controllo e ho visto che praticamente tutte le mod non sono installate...
Che diavolo può essere successo?

Ho provato a reinstallare simply portal e pare sia tornato a funzionare.... grazie a dio con la configurazione che aveva prima.
Cosa devo fare ora? Reinstallare tutte le mod? Ripristinare una versione precedente del forum? (dovrei avere il backup sul server)
hmm... se i mod sono effettivamente disinstallati (e così parrebbe se SP è stato reinstallato senza errori), il suggerimento di Flavio potrebbe non essere la soluzione. L'unica cosa che fa quello script è cambiare lo status da disinstallato a installato.
Ma in questo caso il primo punto è decisamente capire cos'è successo.
1) I mod sono effettivamente disinstallati? Prendine uno che richiede cambiamenti di un file e verifica in quel file se ci sono tracce del mod o no.
2) Indipendentemente da 1, cerca di ricordare cos'hai fatto "recentemente" che può aver causato problemi, magari cancellato file da qualche parte? Ripristinato backup? Altro?

Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 559
    • Mostra profilo
  • Versione SMF: 2.0.x
Re:Tutte le mod "si sono disinstallate"
« Risposta #3 il: Lunedì, 07 Ottobre 2019 20:35 »
 le mod sono disinstallate: ne ho reinstallate alcune e ora funzionano... non ho idea di cosa possa essere successo, non mi pare di aver fatto nulla di strano, se non aver tolto un plugin di wordpress i(defenser o qualcosa...) in un blog di una sottocartella sullo stesso dominio , ma non credo che c'entri... o si?

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4954
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Tutte le mod "si sono disinstallate"
« Risposta #4 il: Martedì, 08 Ottobre 2019 13:09 »
No.
Decisamente no.
Onestamente non saprei cosa dirti.
SMF non disinstalla le cosa a caso, questa è una certezza (anche solo perché non saprebbe come fare).

Online Flavio93Zena

  • Staff IS
  • *******
  • Post: 3035
  • Sesso: Maschio
  • Sniper Legends
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: 1.0.x
Re:Tutte le mod "si sono disinstallate"
« Risposta #5 il: Martedì, 08 Ottobre 2019 14:12 »
...qualcun altro ha accesso admin? Guarda il log di amministrazione se le mod risultano disinstallate da te o chiunque altro.
http://blahblah.com/index.php?action=admin;area=logs;sa=adminlog;

Offline Darknico

  • Amministratore IS
  • *******
  • Post: 2278
  • Sesso: Maschio
  • Server Admin
    • Mostra profilo
    • Darknico.com
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Tutte le mod "si sono disinstallate"
« Risposta #6 il: Martedì, 08 Ottobre 2019 18:41 »
Oppure...hai per caso aggiornato smf?
Non supporto privatamente, non risponderei e ci rimarreste male....





Offline wild56

  • Utente IS Lv.4
  • ****
  • Post: 559
    • Mostra profilo
  • Versione SMF: 2.0.x
Re:Tutte le mod "si sono disinstallate"
« Risposta #7 il: Giovedì, 10 Ottobre 2019 10:03 »
sicuramente non ho fatto aggiornamenti, e non risultano azioni di admin sulle mod
« Ultima modifica: Giovedì, 10 Ottobre 2019 10:09 da wild56 »

Offline Darknico

  • Amministratore IS
  • *******
  • Post: 2278
  • Sesso: Maschio
  • Server Admin
    • Mostra profilo
    • Darknico.com
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Tutte le mod "si sono disinstallate"
« Risposta #8 il: Giovedì, 10 Ottobre 2019 10:10 »
...qualcun altro ha accesso admin? Guarda il log di amministrazione se le mod risultano disinstallate da te o chiunque altro.
http://blahblah.com/index.php?action=admin;area=logs;sa=adminlog;
Non supporto privatamente, non risponderei e ci rimarreste male....





 

Funzione tasto "risolto"

Aperto da titaniumSezione Mods - Modifiche SMF

Risposte: 18
Visite: 4163
Ultimo post Mercoledì, 27 Febbraio 2013 14:36
da titanium
Oggetto dei Topic: eliminare la scritta "Aperto da:"

Aperto da ibernetSezione SMF 2.0

Risposte: 2
Visite: 1528
Ultimo post Martedì, 16 Aprile 2013 12:54
da ibernet
Visualizzare "Sommario del Topic"

Aperto da i_fiorentinoSezione SMF 2.0

Risposte: 22
Visite: 4631
Ultimo post Domenica, 07 Luglio 2013 13:49
da emanuele