Autore Topic: Local con Xampp  (Letto 11082 volte)

0 Utenti e 2 Visitatori stanno visualizzando questo topic.

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5033
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Local con Xampp
« Risposta #30 il: Mercoledì, 10 Luglio 2013 16:49 »
Vai nel pannello di admin, sezione temi e correggi percorsi e url.

Offline titanium

  • Utente IS Lv.4
  • ****
  • Post: 542
  • Sesso: Maschio
  • Maurizio
    • Mostra profilo
    • Idaf.it
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Local con Xampp
« Risposta #31 il: Mercoledì, 10 Luglio 2013 18:31 »
fatto

URL del tema: http://localhost/forum2/Themes/default
URL delle immagini del tema: http://localhost/forum2/Themes/default/images
Cartella del tema: C:\xampp\htdocs\Forum2\Themes\default
Admin of   It. Discussioni Auto Ford

Offline titanium

  • Utente IS Lv.4
  • ****
  • Post: 542
  • Sesso: Maschio
  • Maurizio
    • Mostra profilo
    • Idaf.it
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Local con Xampp
« Risposta #32 il: Sabato, 07 Dicembre 2013 12:22 »
Ho un problema con l'acceso in Xampp.

Vi spiego, avvio XAMPP Control Pannel, e come sempre avvio:

Apache e MySql

poi vado nel browser e dovrei avviare il sito emulato ma niente, La pagina web non è disponibile .

Noto però che dal Control Panel quando avvia i server esce la scritta "Busy" .
Admin of   It. Discussioni Auto Ford

Offline Filippo

  • Traduttore IS
  • *******
  • Post: 1121
  • Sesso: Maschio
    • Mostra profilo
    • Gilera bi4
  • Versione SMF: 2.0.x
Re:Local con Xampp
« Risposta #33 il: Sabato, 07 Dicembre 2013 12:26 »
non saprei, io uso wamp. TEmpo fa dava problemi se skype era avviato prima di wamp. Potrebbe essere lo stesso problema...

Offline titanium

  • Utente IS Lv.4
  • ****
  • Post: 542
  • Sesso: Maschio
  • Maurizio
    • Mostra profilo
    • Idaf.it
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Local con Xampp
« Risposta #34 il: Giovedì, 12 Dicembre 2013 11:26 »
Non lo so.... mi da:

Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

..... ?
Admin of   It. Discussioni Auto Ford

Offline Filippo

  • Traduttore IS
  • *******
  • Post: 1121
  • Sesso: Maschio
    • Mostra profilo
    • Gilera bi4
  • Versione SMF: 2.0.x
Re:Local con Xampp
« Risposta #35 il: Giovedì, 12 Dicembre 2013 17:11 »
boh

Offline Darknico

  • Amministratore IS
  • *******
  • Post: 2426
  • Sesso: Maschio
  • Server Admin
    • Mostra profilo
    • Darknico.com
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Local con Xampp
« Risposta #36 il: Giovedì, 12 Dicembre 2013 17:26 »
Non uso xamp, ma se qualcosa non si avvia correttamente, dubito che funzioni....
Apache sembra sia avviato, ma sembra non collegarsi al database, riesci a verificare che mysql sia attivo? Riesci ad accedere a phpmyadmin?
Non supporto privatamente, non risponderei e ci rimarreste male....





Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5033
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Local con Xampp
« Risposta #37 il: Giovedì, 12 Dicembre 2013 17:34 »
1) mysqld deve essere tra i processi in esecuzione (task manager => processi? boh)
2) password e username mysql devono essere corretti.

Offline titanium

  • Utente IS Lv.4
  • ****
  • Post: 542
  • Sesso: Maschio
  • Maurizio
    • Mostra profilo
    • Idaf.it
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Local con Xampp
« Risposta #38 il: Mercoledì, 12 Dicembre 2018 18:58 »
Non volevo aprire un nuovo topic, pertanto ho deciso di riesumare questo, tra l'altro creato da me un po di tempo fa.

Ho deciso con Xampp di clonare il sito.
Ho tutte le procedure, sino a traferire tutti i file di SMF nella cartella dedicata locale.
Ora come è accaduto anni fa, devo importare il database che di fatto è bello grosso 474Mb, ora ho usato a il programmino SQLDumpSplitter che mi ha scompattato il databese in ben oltre 400 file, che dovrei caricare tutti manualmente, sono arrivato al 16mo file e mi sono annoiato...

Accoratomi dell'errore ho nuovamente usato SQLDumpSplitter per aumentare la dimensione dei file, e di fatto ho ridotto a 200 i file del database da importare (uno a uno).

Ho due quesiti:

- come faccio da http://localhost/phpmyadmin/ ad eliminare le precedenti 16 importazioni?
- esiste una scorciatoia per evitare oltre 200 importazioni manuali?

Grazie e mi scuso se ho sbagliato a riesumare il topic datato.
Admin of   It. Discussioni Auto Ford

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5033
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Local con Xampp
« Risposta #39 il: Mercoledì, 12 Dicembre 2018 20:41 »
Se il problema è caricare il file grosso, credo che il modo più veloce sia cambiare il file di configurazione di apache (che mi pare in xampp sia nella directory httpd... credo) e impostare il limite di upload a 1GB.
Adesso provo ad avviare il portatile e vedere se prima di domani mattina riesco ad aprire la cartella di xampp. xD

Offline Filippo

  • Traduttore IS
  • *******
  • Post: 1121
  • Sesso: Maschio
    • Mostra profilo
    • Gilera bi4
  • Versione SMF: 2.0.x
Re:Local con Xampp
« Risposta #40 il: Giovedì, 13 Dicembre 2018 15:43 »
Conosco wamp e non xampp ma penso sia la stessa cosa. su phpmyadmin c'è una voce "operazioni" e poi trovi "elimina" db. Poi lo ricrei e ricominci l'importazione.

fermo restando, se non ricordo male che se la tabella esiste già l'importazione salta avanti

Offline titanium

  • Utente IS Lv.4
  • ****
  • Post: 542
  • Sesso: Maschio
  • Maurizio
    • Mostra profilo
    • Idaf.it
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Local con Xampp
« Risposta #41 il: Giovedì, 13 Dicembre 2018 15:48 »
Non va allora riepilogo i passi fatti:

1. installato Xampp
2. avviato il control panel ;
3. all'interno della cartella C  > xampp > htdocs > forum  , ho copiato tutti i file del forum (fatta eccezione degli allegati ovvero cartella attachments;
4. importato tutto il databese modificando i parametri del php.ini di xampp elevandoli a 500M;
5. copiato il file repair_settings
6. avviato il file di prima, mi si apre la schermata inserisco tutti i dati che lui mi raccomanda di fare, i dati del database sono quelli giusti, nome, userid e psw, solo che in cima alla pagina di SMF 2.0 Settings Repair Tool compare sempre questa dicitura:

Some settings are not being shown because the database connection information is incorrect.
Check your database login details, table prefix and that the database actually contains your SMF tables.

7. salvato il tutto, sul browser scrivo http://localhost/forum/ ma non mi esce il mio sito ma:

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

Dove sto sbagliando?
Admin of   It. Discussioni Auto Ford

Offline Filippo

  • Traduttore IS
  • *******
  • Post: 1121
  • Sesso: Maschio
    • Mostra profilo
    • Gilera bi4
  • Versione SMF: 2.0.x
Re:Local con Xampp
« Risposta #42 il: Giovedì, 13 Dicembre 2018 15:56 »
Probabilmente nelle informazioni del repair settings


Offline titanium

  • Utente IS Lv.4
  • ****
  • Post: 542
  • Sesso: Maschio
  • Maurizio
    • Mostra profilo
    • Idaf.it
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:Local con Xampp
« Risposta #43 il: Giovedì, 13 Dicembre 2018 15:58 »
Credo di aver fatto tutto corretto.
« Ultima modifica: Giovedì, 13 Dicembre 2018 16:04 da titanium »
Admin of   It. Discussioni Auto Ford

Offline Filippo

  • Traduttore IS
  • *******
  • Post: 1121
  • Sesso: Maschio
    • Mostra profilo
    • Gilera bi4
  • Versione SMF: 2.0.x
Re:Local con Xampp
« Risposta #44 il: Giovedì, 13 Dicembre 2018 16:07 »
Quelli che hai cancellato devono essere quelli che hai immesso su xampp, naturalmente

 

xampp installazione e configurazone

Aperto da pieroSezione SMF 2.0

Risposte: 10
Visite: 1508
Ultimo post Mercoledì, 11 Marzo 2015 11:27
da piero
SimplePortal 2.3.7 © 2008-2018, SimplePortal