Autore Topic: Email di attivazione che arrivano vuote  (Letto 8201 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4960
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Email di attivazione che arrivano vuote
« Risposta #15 il: Sabato, 30 Novembre 2013 13:49 »
...ok, questo non me l'aspettavo... ???
Quanto odio i charset!!! *rage*

Altra dovresti controllare un'altra cosa: vai in phpmyadmin, subito nella prima pagine, sulla destra, ci dovrebbe essere un riquadro con alcune informazioni, tra cui "charset del database" (o dicitura simile), cosa dice? utf8 o latin_swedish?
Dopo, seleziona il tuo database, ti ritrovi la schermata con tutte le tabelle, nella colonna "collation" cosa c'è scritto per la tabella "smf_messages"?
Entra in smf_messages, clicca "struttura" (in alto), quindi scorri fino a trovare "body", nella colonna "collation" cosa c'è scritto?

Offline pelotas84

  • Utente IS
  • *
  • Post: 27
  • Sesso: Maschio
  • Via dove ti porta il mono...
    • Mostra profilo
    • www.romamotard.it
  • Versione SMF: 1.1.x
Re:Email di attivazione che arrivano vuote
« Risposta #16 il: Sabato, 30 Novembre 2013 15:32 »
allora:

1 risposta



2 risposta

 sotto collation c'è riportato "utf8_general_ci"

3 risposta

 accanto a Body c'è sempre "utf8_general_ci"

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4960
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Email di attivazione che arrivano vuote
« Risposta #17 il: Venerdì, 13 Dicembre 2013 12:17 »
SCUSA!!

Dovevi ri-postare quando hai visto che nessuno rispondeva! :-[

Prova ad aggiungere
Codice: [Seleziona]
$db_character_set = 'utf8'; a Settings.php, prima dell'ultima riga (quella che contiene ?>) creane una nuova e mettici dentro quella riga, poi prova a controllare se le lettere accentate dei post sono corrette e se postando lettere accentate i messaggi passano correttamente. Se dovesse esserci un qualunque problema toglilo subito e descrivi bene cosa non ha funzionato. ;)

Offline pelotas84

  • Utente IS
  • *
  • Post: 27
  • Sesso: Maschio
  • Via dove ti porta il mono...
    • Mostra profilo
    • www.romamotard.it
  • Versione SMF: 1.1.x
Re:Email di attivazione che arrivano vuote
« Risposta #18 il: Venerdì, 13 Dicembre 2013 17:18 »
SCUSA!!

Dovevi ri-postare quando hai visto che nessuno rispondeva! :-[

Prova ad aggiungere
Codice: [Seleziona]
$db_character_set = 'utf8'; a Settings.php, prima dell'ultima riga (quella che contiene ?>) creane una nuova e mettici dentro quella riga, poi prova a controllare se le lettere accentate dei post sono corrette e se postando lettere accentate i messaggi passano correttamente. Se dovesse esserci un qualunque problema toglilo subito e descrivi bene cosa non ha funzionato. ;)
Prova effettuata,di file Settings.php ne ho due, uno in una cartella chiamata "Forum" e l'altro in una cartella chiamata "Forum2" (non chiedermi perchè, alcune cose sono su una e alcune su l'altra).
Nel file settings.php della cartella "Forum" la dicitura "$db_character_set = 'utf8';" già c'era (quindi non ho toccato nulla).
Nel file settings.php della cartella "Forum2" NON c'era e provando ad aggiungerlo non cambia assolutamente nulla.
Quindi in conclusione suppongo che le modifiche dovro farle nella cartella "Forum" e comunque sia la stringa $db_character_set = 'utf8'; è già compresa.

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4960
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Email di attivazione che arrivano vuote
« Risposta #19 il: Venerdì, 13 Dicembre 2013 19:40 »
In effetti mi sembrava strano, ma prima mi avevi detto che non c'era... xD :P
Va beh, poco male.

Probabilmente allora è solo un problema di lingua.
Fai un backup almeno dei file di lingua così che se hai qualche traduzione in giro te la salvi.

Io suggerirei questo:
* imposta come default l'inglese e resetta a tutti gli utenti l'inglese,
* disinstalla l'italiano (probabilmente ne hai due installati, toglili entrambi),
* ripeti l'installazione dell'italiano scegliendo la versione UTF8,
* imposta nuovamente l'italiano come lingua di default.

* emanuele incrocia le dita.

Offline pelotas84

  • Utente IS
  • *
  • Post: 27
  • Sesso: Maschio
  • Via dove ti porta il mono...
    • Mostra profilo
    • www.romamotard.it
  • Versione SMF: 1.1.x
Re:Email di attivazione che arrivano vuote
« Risposta #20 il: Venerdì, 13 Dicembre 2013 22:02 »
Alla fine ho preferito ripristinare tutti i file della lingua, come mi hai consigliato per risolvere il problema degli accenti, ed indovina un po?
Adesso le mail arrivano e si vedono correttamente!!
TI STO PER AMARE LO SAI ? ;D ;D ;D ;D ;D ;D
non mi sembra vero che ho risolto, GRAZIE GRAZIE GRAZIE!!!!

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 4960
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:Email di attivazione che arrivano vuote
« Risposta #21 il: Venerdì, 13 Dicembre 2013 23:19 »
* emanuele facendo l'indifferente si allontana silenziosamente e si nasconde lol

 

notifiche email non arrivano

Aperto da liku337Sezione SMF 2.0

Risposte: 33
Visite: 1132
Ultimo post Lunedì, 25 Febbraio 2019 18:14
da emanuele
Non arrivano le notifiche dopo un trasloco

Aperto da TanakaSezione SMF 2.0

Risposte: 8
Visite: 1928
Ultimo post Sabato, 27 Dicembre 2014 13:36
da emanuele
verifica email esistenti

Aperto da xena1997Sezione Mods - Modifiche SMF

Risposte: 3
Visite: 1485
Ultimo post Lunedì, 12 Gennaio 2015 06:57
da xena1997