Autore Topic: 2.0.8 - Aggiornamento  (Letto 2330 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Tanaka

  • Utente IS Lv.2
  • **
  • Post: 192
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
2.0.8 - Aggiornamento
« il: Sabato, 21 Giugno 2014 09:40 »
Non riesco ad aggiornare .

Sono rimasto un po' indietro e le mie condizioni sono :

File SMF                   Versione installata          Ultima versione
Pacchetto SMF                   SMF 2.0.8                       SMF 2.0.8
Sorgenti                               2.0.4                      2.0.8
Template predefiniti                      2.0                      2.0.7
File di traduzione                      2.0                      2.0.8
Template in uso                      2.0                         2.0

Non ho idea di come mai mi segnali che ho la versione 2.0.8, forse perchè ho aggiornato le lingue ?

In ogni caso, quando tento l'upgrade ricevo questo errore :

Codice: [Seleziona]

The upgrader found some old or outdated language files, for the forum default language, italian-utf8.

Please make certain you uploaded the new versions of all the files included in the package, even the theme and language files for the default theme.
   [SKIP] [Try English]



Strano .. ho aggiornato sia l'italiano che l'inglese ed ho verificato che le diciture nei file, proprio come indicato da Darknico, fossero corrette.

Cosa sbaglio ?


T.

Offline Darknico

  • Amministratore IS
  • *******
  • Post: 2458
  • Sesso: Maschio
  • Server Admin
    • Mostra profilo
    • Darknico.com
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:2.0.8 - Aggiornamento
« Risposta #1 il: Sabato, 21 Giugno 2014 11:00 »
Perchè stai effettuando un large upgrade? Così facendo perdi tutte le mods installate..
Comunque basta premere su [Try English] e l'operazione va avanti...
Non supporto privatamente, non risponderei e ci rimarreste male....





Offline Tanaka

  • Utente IS Lv.2
  • **
  • Post: 192
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:2.0.8 - Aggiornamento
« Risposta #2 il: Lunedì, 23 Giugno 2014 17:16 »
Ciao Darknico e grazie,

sì, sto effettuando un large upgrade. Sono rimasto indietro con le versioni e credevo fosse l'unico modo possibile.
In verità, anche selezionando lì'inglese, non va avanti ugualmente, mi restituisce lo stesso errore per entrambe le lingue.

T.

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5056
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:2.0.8 - Aggiornamento
« Risposta #3 il: Lunedì, 23 Giugno 2014 17:35 »
Premi "SKIP". ;)

Offline Tanaka

  • Utente IS Lv.2
  • **
  • Post: 192
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:2.0.8 - Aggiornamento
« Risposta #4 il: Martedì, 24 Giugno 2014 20:55 »
Grazie Emanuele, ho provato, ma mi dà errore lo stesso; non si muove da lì ..


T.

Offline Darknico

  • Amministratore IS
  • *******
  • Post: 2458
  • Sesso: Maschio
  • Server Admin
    • Mostra profilo
    • Darknico.com
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:2.0.8 - Aggiornamento
« Risposta #5 il: Martedì, 24 Giugno 2014 21:18 »
Link al sito?
Non supporto privatamente, non risponderei e ci rimarreste male....





Offline Tanaka

  • Utente IS Lv.2
  • **
  • Post: 192
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:2.0.8 - Aggiornamento
« Risposta #6 il: Martedì, 24 Giugno 2014 21:59 »
Ciao Darkniko e grazie,

adesso è finalmente partito . Però mi ha dato un paio di errori durante e mi ha eliminato ( oltre a tutte le mod, che sapevo ) anche molte board.
Fortunatamente sto facendo il tutto in una area test e non sul forum originale ..

Ho chiuso il sito in manutenzione e credo che il link non ti servirebbe .

Domanda idiota : Conviene davvero upgradare ?

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5056
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:2.0.8 - Aggiornamento
« Risposta #7 il: Martedì, 24 Giugno 2014 23:36 »
adesso è finalmente partito . Però mi ha dato un paio di errori durante e mi ha eliminato ( oltre a tutte le mod, che sapevo ) anche molte board.
Estremamente improbabile.
Per quanto l'upgrade possa essere un pezzo di codice spaventoso, mi suona molto, ma molto strano che abbia cancellato qualcosa, soprattutto perché in un caso come questo l'upgrade non fa praticamente niente.

Fortunatamente sto facendo il tutto in una area test e non sul forum originale ..
Sicuro che avessi quelle board?
Ad ogni modo, può anche solo essere un qualche errore che se ne va facendo la manutenzione del db (admin > manutenzione).

Domanda idiota : Conviene davvero upgradare ?
Normalmente conviene installare il pacchetto e basta facendo un update.
In questo specifico caso, sì e no, ma siccome eventuali successivi aggiornamenti richiederanno la presenza di questi è qualcosa che prima o poi ti tocca fare...

Offline Tanaka

  • Utente IS Lv.2
  • **
  • Post: 192
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:2.0.8 - Aggiornamento
« Risposta #8 il: Mercoledì, 25 Giugno 2014 10:17 »
Anzitutto Grazie Emanuele, sempre disponibile .

adesso è finalmente partito . Però mi ha dato un paio di errori durante e mi ha eliminato ( oltre a tutte le mod, che sapevo ) anche molte board.
Estremamente improbabile.
Per quanto l'upgrade possa essere un pezzo di codice spaventoso, mi suona molto, ma molto strano che abbia cancellato qualcosa, soprattutto perché in un caso come questo l'upgrade non fa praticamente niente.

Non so che dire... Appena posso riprovo. Fortuna ho una testarea.


Fortunatamente sto facendo il tutto in una area test e non sul forum originale ..
Sicuro che avessi quelle board?
Ad ogni modo, può anche solo essere un qualche errore che se ne va facendo la manutenzione del db (admin > manutenzione).

Ho provato, ma niente da fare .. Sono certissimo di averle avute, le ho ancora nel forum aperto al pubblico.

Domanda idiota : Conviene davvero upgradare ?
Normalmente conviene installare il pacchetto e basta facendo un update.
In questo specifico caso, sì e no, ma siccome eventuali successivi aggiornamenti richiederanno la presenza di questi è qualcosa che prima o poi ti tocca fare...

Il mio problema è che sembra esserci una incongruenza tra i file, i db e le varie versioni. Devo aver fatto confusione quando ho fatto gli upgrade, anche se non so bene dove ho sbagliato perchè ho semrpe caricato dal normale pannello dei pacchetti .


Grazie per adesso !!!

Riprovo da capo e poi vi dico .


T.

Offline Tanaka

  • Utente IS Lv.2
  • **
  • Post: 192
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:2.0.8 - Aggiornamento
« Risposta #9 il: Mercoledì, 25 Giugno 2014 19:25 »
Ok, alla fine . scegliendo la via più lunga, cioè di fare tutto attraverso i pacchetti , la cosa è andata bene.

Ero rimasto al 2.0.6 e ho dovuto caricare gli ultimi due. Ho dovuto modificare alcuni files, ma sembra che la cosa sia andata ( adesso testo per qualche giorno prima di farlo nel forum "vero" ) .

Domanda: in questo modo però non ho modificato il db, cosa che l'upgrade se non erro, fa .. mi mancherà qualcosa ?

Grazie !

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5056
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:2.0.8 - Aggiornamento
« Risposta #10 il: Mercoledì, 25 Giugno 2014 20:56 »
In questi update niente.
Se dovesse essere cambiato qualcosa nel db, anche le patch vengono create in modo che il database venga aggiornato, se non c'è niente da aggiornare, ovviamente non viene aggiunto il relativo codice.

Offline Tanaka

  • Utente IS Lv.2
  • **
  • Post: 192
    • Mostra profilo
  • Versione SMF: 2.0.x
  • Versione ElkArte: -
Re:2.0.8 - Aggiornamento
« Risposta #11 il: Sabato, 28 Giugno 2014 15:59 »
Ah, ok, grazie.

Lo chiedo perchè di tanto in tanto mi ritrovo il forum in down con un errore che mi avverte che il db pare essere di una versione antecedente ai files . Poi però tutto si risistema con un riavvio del VPS su cui sono ospitato.

T.

Offline emanuele

  • Amministratore IS
  • *******
  • Post: 5056
    • Mostra profilo
    • ElkArte
  • Versione SMF: Altro
  • Versione ElkArte: 1.0.x
Re:2.0.8 - Aggiornamento
« Risposta #12 il: Sabato, 28 Giugno 2014 21:36 »
Quello è un messaggio d'errore "normale": SMF si trova un errore relativo al database, la revisione del db viene aggiornata solo quando vengono effettuate modifiche al db stesso, quindi se index.php contiene la versione 2.0.8 il db potrebbe tranquillamente essere a 2.0 perché non ha mai avuto bisogno di aggiornamenti e quindi i due valori non combaciano e l'unica cosa che SMF ti può suggerire è che magari il db non è aggiornato.

 

2.0.4 - Aggiornamento traduzione

Aperto da DarknicoSezione Traduzione Core

Risposte: 0
Visite: 2893
Ultimo post Martedì, 05 Febbraio 2013 09:36
da Darknico
Aggiornamento del Forum SMF

Aperto da DarknicoSezione Guide - Trucchi

Risposte: 0
Visite: 5494
Ultimo post Sabato, 09 Febbraio 2013 14:32
da Darknico
2.0.7 - Aggiornamento traduzione

Aperto da DarknicoSezione Traduzione Core

Risposte: 3
Visite: 2321
Ultimo post Venerdì, 14 Febbraio 2014 10:02
da Darknico
SimplePortal 2.3.7 © 2008-2018, SimplePortal